blob: 40df7042e6529a7693542767446e0dfed690c390 [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001SUMMARY = "Framework for layout and rendering of internationalized text"
2DESCRIPTION = "Pango is a library for laying out and rendering of text, \
3with an emphasis on internationalization. Pango can be used anywhere \
4that text layout is needed, though most of the work on Pango so far has \
5been done in the context of the GTK+ widget toolkit. Pango forms the \
6core of text and font handling for GTK+-2.x."
7HOMEPAGE = "http://www.pango.org/"
8BUGTRACKER = "http://bugzilla.gnome.org"
9SECTION = "libs"
10LICENSE = "LGPLv2.0+"
11
12LIC_FILES_CHKSUM = "file://COPYING;md5=3bf50002aefd002f49e7bb854063f7e7"
13
14GNOMEBASEBUILDCLASS = "meson"
15
16inherit gnomebase gi-docgen ptest-gnome upstream-version-is-even gobject-introspection
17
18GIR_MESON_ENABLE_FLAG = "enabled"
19GIR_MESON_DISABLE_FLAG = "disabled"
20
21SRC_URI += "file://run-ptest"
22
23SRC_URI[archive.sha256sum] = "21e1f5798bcdfda75eabc4280514b0896ab56f656d4e7e66030b9a2535ecdc98"
24
25DEPENDS = "glib-2.0 glib-2.0-native fontconfig freetype virtual/libiconv cairo harfbuzz fribidi"
26
27PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)} \
28 ${@bb.utils.contains('PTEST_ENABLED', '1', 'tests', '', d)}"
29
30PACKAGECONFIG[x11] = ",,virtual/libx11 libxft"
31PACKAGECONFIG[tests] = "-Dinstall-tests=true, -Dinstall-tests=false"
32PACKAGECONFIG[thai] = ",,libthai"
33
34GIR_MESON_OPTION = 'introspection'
35
36do_configure:prepend() {
37 chmod +x ${S}/tests/*.py
38}
39
40do_configure:prepend:toolchain-clang() {
41 sed -i -e "/Werror=implicit-fallthrough/d" ${S}/meson.build
42}
43
44LEAD_SONAME = "libpango-1.0*"
45
46FILES:${PN} = "${bindir}/* ${libdir}/libpango*${SOLIBS}"
47
48RDEPENDS:${PN}-ptest += "cantarell-fonts"
49RDEPENDS:${PN}-ptest:append:libc-glibc = " locale-base-en-us"
50
51RPROVIDES:${PN} += "pango-modules pango-module-indic-lang \
52 pango-module-basic-fc pango-module-arabic-lang"
53
54BBCLASSEXTEND = "native nativesdk"