blob: cc2cfc18a87921ab2d0670ff759a3aabd314eec0 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "A collection of tools, libraries and tests for shader compilation"
2DESCRIPTION = "The Shaderc library provides an API for compiling GLSL/HLSL \
3source code to SPIRV modules. It has been shipping in the Android NDK since version r12b."
4SECTION = "graphics"
5HOMEPAGE = "https://github.com/google/shaderc"
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
8
9SRCREV = "6fabc36fbebacfcef8cf82463df2a8247120ebf0"
10SRC_URI = "git://github.com/google/shaderc.git;protocol=https;branch=main \
11 file://0001-cmake-disable-building-external-dependencies.patch \
12 file://0002-libshaderc_util-fix-glslang-header-file-location.patch \
13 "
14UPSTREAM_CHECK_GITTAGREGEX = "^v(?P<pver>\d+(\.\d+)+)$"
15S = "${WORKDIR}/git"
16
17inherit cmake python3native pkgconfig
18
19DEPENDS = "spirv-headers spirv-tools glslang"
20
21EXTRA_OECMAKE = " \
22 -DCMAKE_BUILD_TYPE=Release \
23 -DBUILD_EXTERNAL=OFF \
24 -DSHADERC_SKIP_TESTS=ON \
25 -DSHADERC_SKIP_EXAMPLES=ON \
26 -DSHADERC_SKIP_COPYRIGHT_CHECK=ON \
27"
28
29BBCLASSEXTEND = "native nativesdk"