blob: 7c5079c452ca164a6bca3052d19b11c127fde2e3 [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001SUMMARY = "Generic XKB keymap library"
2DESCRIPTION = "libxkbcommon is a keymap compiler and support library which \
3processes a reduced subset of keymaps as defined by the XKB specification."
4HOMEPAGE = "http://www.xkbcommon.org"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=e525ed9809e1f8a07cf4bce8b09e8b87"
6LICENSE = "MIT & MIT-style"
7
Andrew Geissler595f6302022-01-24 19:11:47 +00008DEPENDS = "flex-native bison-native"
Andrew Geisslereff27472021-10-29 15:35:00 -05009
10SRC_URI = "http://xkbcommon.org/download/${BPN}-${PV}.tar.xz"
11
12SRC_URI[sha256sum] = "b3c710d27a2630054e1e1399c85b7f330ef03359b460f0c1b3b587fd01fe9234"
13
14UPSTREAM_CHECK_URI = "http://xkbcommon.org/"
15
16inherit meson pkgconfig
17
Andrew Geissler595f6302022-01-24 19:11:47 +000018PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'x11 wayland', d)} xkbregistry"
Andrew Geisslereff27472021-10-29 15:35:00 -050019
Andrew Geissler595f6302022-01-24 19:11:47 +000020PACKAGECONFIG[docs] = "-Denable-docs=true,-Denable-docs=false,doxygen-native"
Andrew Geisslereff27472021-10-29 15:35:00 -050021PACKAGECONFIG[wayland] = "-Denable-wayland=true,-Denable-wayland=false,wayland-native wayland wayland-protocols,"
Andrew Geissler595f6302022-01-24 19:11:47 +000022PACKAGECONFIG[x11] = "-Denable-x11=true,-Denable-x11=false,libxcb xkeyboard-config,"
23PACKAGECONFIG[xkbregistry] = "-Denable-xkbregistry=true,-Denable-xkbregistry=false,libxml2"
24
25PACKAGE_BEFORE_PN += "xkbcli"
26FILES:${PN} = ""
27FILES:xkbcli = "${bindir}/xkbcli ${libexecdir}/xkbcommon/xkbcli-*"
28
29python populate_packages:prepend () {
30 # Put the libraries into separate packages to avoid dependency creep
31 do_split_packages(d, d.expand('${libdir}'), r'^(lib.*)\.so\.*', '%s', '%s library', extra_depends='', allow_links=True)
32}
Andrew Geisslereff27472021-10-29 15:35:00 -050033
34# Fix a following runtime error:
35# xkbcommon: ERROR: couldn't find a Compose file for locale "C"
36RDEPENDS:${PN} = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libx11-locale', 'libx11-compose-data', d)}"