blob: 1dd7d0d09a35040fcd02169655f1632653e930e0 [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001SUMMARY = "Python bindings for GStreamer 1.0"
2DESCRIPTION = "GStreamer Python binding overrides (complementing the bindings \
3provided by python-gi) "
4HOMEPAGE = "http://cgit.freedesktop.org/gstreamer/gst-python/"
5SECTION = "multimedia"
6
7LICENSE = "LGPLv2.1"
8LIC_FILES_CHKSUM = "file://COPYING;md5=c34deae4e395ca07e725ab0076a5f740"
9
10SRC_URI = "https://gstreamer.freedesktop.org/src/${PNREAL}/${PNREAL}-${PV}.tar.xz"
11SRC_URI[sha256sum] = "533685871305959d6db89507f3b3aa6c765c2f2b0dacdc32c5a6543e72e5bc52"
12
13DEPENDS = "gstreamer1.0 gstreamer1.0-plugins-base python3-pygobject"
14RDEPENDS:${PN} += "gstreamer1.0 gstreamer1.0-plugins-base python3-pygobject"
15
16PNREAL = "gst-python"
17
18S = "${WORKDIR}/${PNREAL}-${PV}"
19
20EXTRA_OEMESON += "-Dlibpython-dir=${libdir}"
21
22# gobject-introspection is mandatory and cannot be configured
23REQUIRED_DISTRO_FEATURES = "gobject-introspection-data"
Andrew Geissler595f6302022-01-24 19:11:47 +000024GIR_MESON_OPTION = ""
Andrew Geisslereff27472021-10-29 15:35:00 -050025
Andrew Geissler595f6302022-01-24 19:11:47 +000026inherit meson pkgconfig setuptools3-base upstream-version-is-even gobject-introspection features_check