blob: 0d82dd338c35c973da9e1b1762aa0c71a3a4e0c2 [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001SUMMARY = "GStreamer 1.0 multimedia framework"
2DESCRIPTION = "GStreamer is a multimedia framework for encoding and decoding video and sound. \
3It supports a wide range of formats including mp3, ogg, avi, mpeg and quicktime."
4HOMEPAGE = "http://gstreamer.freedesktop.org/"
5BUGTRACKER = "https://bugzilla.gnome.org/enter_bug.cgi?product=Gstreamer"
6SECTION = "multimedia"
7LICENSE = "LGPLv2+"
8
9DEPENDS = "glib-2.0 glib-2.0-native libxml2 bison-native flex-native"
10
11inherit meson pkgconfig gettext upstream-version-is-even gobject-introspection ptest-gnome
12
13LIC_FILES_CHKSUM = "file://COPYING;md5=6762ed442b3822387a51c92d928ead0d \
14 file://gst/gst.h;beginline=1;endline=21;md5=e059138481205ee2c6fc1c079c016d0d"
15
16S = "${WORKDIR}/gstreamer-${PV}"
17
18SRC_URI = "https://gstreamer.freedesktop.org/src/gstreamer/gstreamer-${PV}.tar.xz \
19 file://run-ptest \
20 file://0001-gst-gstpluginloader.c-when-env-var-is-set-do-not-fal.patch \
21 file://0002-Remove-unused-valgrind-detection.patch \
22 file://0003-tests-seek-Don-t-use-too-strict-timeout-for-validati.patch \
23 file://0004-tests-respect-the-idententaion-used-in-meson.patch \
24 file://0005-tests-add-support-for-install-the-tests.patch \
25 file://0006-tests-use-a-dictionaries-for-environment.patch \
26 file://0007-tests-install-the-environment-for-installed_tests.patch \
27 "
28SRC_URI[sha256sum] = "55862232a63459bbf56abebde3085ca9aec211b478e891dacea4d6df8cafe80a"
29
30PACKAGECONFIG ??= "${@bb.utils.contains('PTEST_ENABLED', '1', 'tests', '', d)} \
31 check \
32 debug \
33 tools"
34
35PACKAGECONFIG[debug] = "-Dgst_debug=true,-Dgst_debug=false"
36PACKAGECONFIG[tracer-hooks] = "-Dtracer_hooks=true,-Dtracer_hooks=false"
37PACKAGECONFIG[coretracers] = "-Dcoretracers=enabled,-Dcoretracers=disabled"
38PACKAGECONFIG[check] = "-Dcheck=enabled,-Dcheck=disabled"
39PACKAGECONFIG[tests] = "-Dtests=enabled -Dinstalled-tests=true,-Dtests=disabled -Dinstalled-tests=false"
40PACKAGECONFIG[unwind] = "-Dlibunwind=enabled,-Dlibunwind=disabled,libunwind"
41PACKAGECONFIG[dw] = "-Dlibdw=enabled,-Dlibdw=disabled,elfutils"
42PACKAGECONFIG[bash-completion] = "-Dbash-completion=enabled,-Dbash-completion=disabled,bash-completion"
43PACKAGECONFIG[tools] = "-Dtools=enabled,-Dtools=disabled"
44PACKAGECONFIG[setcap] = "-Dptp-helper-permissions=capabilities,,libcap libcap-native"
45
46# TODO: put this in a gettext.bbclass patch
47def gettext_oemeson(d):
48 if d.getVar('USE_NLS') == 'no':
49 return '-Dnls=disabled'
50 # Remove the NLS bits if USE_NLS is no or INHIBIT_DEFAULT_DEPS is set
51 if d.getVar('INHIBIT_DEFAULT_DEPS') and not oe.utils.inherits(d, 'cross-canadian'):
52 return '-Dnls=disabled'
53 return '-Dnls=enabled'
54
55EXTRA_OEMESON += " \
56 -Ddoc=disabled \
57 -Dexamples=disabled \
58 -Ddbghelp=disabled \
59 ${@gettext_oemeson(d)} \
60"
61
62GIR_MESON_ENABLE_FLAG = "enabled"
63GIR_MESON_DISABLE_FLAG = "disabled"
64
65PACKAGES += "${PN}-bash-completion"
66
67# Add the core element plugins to the main package
68FILES:${PN} += "${libdir}/gstreamer-1.0/*.so"
69FILES:${PN}-dev += "${libdir}/gstreamer-1.0/*.a ${libdir}/gstreamer-1.0/include"
70FILES:${PN}-bash-completion += "${datadir}/bash-completion/completions/ ${datadir}/bash-completion/helpers/gst*"
71FILES:${PN}-dbg += "${datadir}/gdb ${datadir}/gstreamer-1.0/gdb"
72
73CVE_PRODUCT = "gstreamer"
74
75PTEST_BUILD_HOST_FILES = ""