blob: fe3824b8e022bd55f38799cf861b176deaf31845 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Small library that defines common error values for all GnuPG components"
2DESCRIPTION = "Contains common error codes and error handling functions used by GnuPG, Libgcrypt, GPGME and more packages. "
3HOMEPAGE = "http://www.gnupg.org/related_software/libgpg-error/"
4BUGTRACKER = "https://bugs.g10code.com/gnupg/index"
5
6LICENSE = "GPLv2+ & LGPLv2.1+"
7LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \
8 file://COPYING.LIB;md5=2d5025d4aa3495befef8f17206a5b0a1 \
9 file://src/gpg-error.h.in;beginline=2;endline=18;md5=d82591bc81561f617da71e00ff4a9d79 \
10 file://src/init.c;beginline=2;endline=17;md5=f01cdfcf747af5380590cfd9bbfeaaf7 \
11 "
12
13
14SECTION = "libs"
15
16UPSTREAM_CHECK_URI = "https://gnupg.org/download/index.html"
17SRC_URI = "${GNUPG_MIRROR}/libgpg-error/libgpg-error-${PV}.tar.bz2 \
18 file://pkgconfig.patch \
19 file://0001-Do-not-fail-when-testing-config-scripts.patch \
20 file://0001-configure.ac-do-not-hardcode-gnu-libc-when-generatin.patch \
21 "
22
23SRC_URI[sha256sum] = "a9ab83ca7acc442a5bd846a75b920285ff79bdb4e3d34aa382be88ed2c3aebaf"
24
25BINCONFIG = "${bindir}/gpg-error-config"
26
27inherit autotools binconfig-disabled pkgconfig gettext multilib_header multilib_script
28
29MULTILIB_SCRIPTS = "${PN}-dev:${bindir}/gpgrt-config"
30
31CPPFLAGS += "-P"
32
33do_install:append() {
34 # we don't have common lisp in OE
35 rm -rf "${D}${datadir}/common-lisp/"
36 oe_multilib_header gpg-error.h gpgrt.h
37}
38
39FILES:${PN}-dev += "${bindir}/gpg-error"
40FILES:${PN}-doc += "${datadir}/libgpg-error/errorref.txt"
41
42BBCLASSEXTEND = "native nativesdk"