blob: 00ab58b38cf15ccdda78263e4e2277dc2032cb20 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Shadow utils requirements for useradd.bbclass"
Brad Bishopf3f93bb2019-10-16 14:33:32 -04002HOMEPAGE = "http://github.com/shadow-maint/shadow"
3BUGTRACKER = "http://github.com/shadow-maint/shadow/issues"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05004SECTION = "base utils"
Andrew Geissler5199d832021-09-24 16:47:35 -05005LICENSE = "BSD-3-Clause | Artistic-1.0"
Andrew Geissler8f840682023-07-21 09:09:43 -05006LIC_FILES_CHKSUM = "file://login.defs_shadow-sysroot;endline=1;md5=ceddfb61608e4db87012499555184aed"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05007
8DEPENDS = "base-passwd"
9
Patrick Williamsc124f4f2015-09-15 14:41:29 -050010
11# The sole purpose of this recipe is to provide the /etc/login.defs
12# file for the target sysroot - needed so the shadow-native utilities
13# can add custom users/groups for recipes that use inherit useradd.
14SRC_URI = "file://login.defs_shadow-sysroot"
15
Patrick Williamsc124f4f2015-09-15 14:41:29 -050016S = "${WORKDIR}"
17
18do_install() {
19 install -d ${D}${sysconfdir}
Patrick Williamsc0f7c042017-02-23 20:41:17 -060020 install -p -m 644 ${S}/login.defs_shadow-sysroot ${D}${sysconfdir}/login.defs
Patrick Williamsc124f4f2015-09-15 14:41:29 -050021}
22
Patrick Williamsc0f7c042017-02-23 20:41:17 -060023SYSROOT_DIRS += "${sysconfdir}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050024
25# don't create any packages
Brad Bishopf3f93bb2019-10-16 14:33:32 -040026# otherwise: dbus-dev depends on shadow-sysroot-dev which depends on shadow-sysroot
Patrick Williamsc124f4f2015-09-15 14:41:29 -050027# and this has another copy of /etc/login.defs already provided by shadow
28PACKAGES = ""
Andrew Geisslerf0343792020-11-18 10:42:21 -060029
30inherit nopackages