blob: 263de81c7004097b740718c61a9651b58dbbf151 [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001SUMMARY = "C++ library for client-side URL transfers"
2HOMEPAGE = "http://www.curlpp.org/"
3SECTION = "libdevel"
4LICENSE = "MIT"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08005LIC_FILES_CHKSUM = "file://doc/LICENSE;md5=fd0c9adf285a69aa3b4faf34384e1029"
Brad Bishop6e60e8b2018-02-01 10:27:11 -05006
7DEPENDS = "curl"
Patrick Williams213cb262021-08-07 19:21:33 -05008DEPENDS:class-native = "curl-native"
Brad Bishop6e60e8b2018-02-01 10:27:11 -05009
10SRC_URI = "git://github.com/jpbarrette/curlpp.git"
11
12SRCREV = "592552a165cc569dac7674cb7fc9de3dc829906f"
13
14S = "${WORKDIR}/git"
15
16inherit cmake pkgconfig binconfig
17
Brad Bishop6e60e8b2018-02-01 10:27:11 -050018BBCLASSEXTEND = "native nativesdk"
Patrick Williams0ca19cc2021-08-16 14:03:13 -050019
20do_install:append() {
21 sed -e 's@[^ ]*-ffile-prefix-map=[^ "]*@@g' \
22 -e 's@[^ ]*-fdebug-prefix-map=[^ "]*@@g' \
23 -e 's@[^ ]*-fmacro-prefix-map=[^ "]*@@g' \
24 -i ${D}${libdir}/pkgconfig/*.pc
25}