blob: f04ff01d96ef38a0ee255576513a48715139010b [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Opensource Implementation of WS-Management"
2DESCRIPTION = "Openwsman is a project intended to provide an open-source \
3implementation of the Web Services Management specipication \
4(WS-Management) and to expose system management information on the \
5Linux operating system using the WS-Management protocol. WS-Management \
6is based on a suite of web services specifications and usage \
7requirements that exposes a set of operations focused on and covers \
8all system management aspects. \
9Openwsman Server and service libraries"
10HOMEPAGE = "http://www.openwsman.org/"
11SECTION = "Applications/System"
12
13DEPENDS = "curl libxml2 openssl libpam"
14
15inherit distro_features_check
16REQUIRED_DISTRO_FEATURES = "pam"
17
18# v2.6.8
19SRCREV = "b9cd0b72534854abb6dd834c8c11e02111b4c8d7"
20
21SRC_URI = "git://github.com/Openwsman/openwsman.git \
22 file://libssl-is-required-if-eventint-supported.patch \
23 file://openwsmand.service \
24 file://0001-lock.c-Define-PTHREAD_MUTEX_RECURSIVE_NP-if-undefine.patch \
25 file://0001-openSSL-1.1.0-API-fixes.patch \
26 file://0001-Adjust-for-CURLE_SSL_CACERT-deprecation-in-curl-7.62.patch \
27 "
28
29S = "${WORKDIR}/git"
30
31LICENSE = "BSD"
32LIC_FILES_CHKSUM = "file://COPYING;md5=d4f53d4c6cf73b9d43186ce3be6dd0ba"
33
34inherit systemd cmake pkgconfig python3native perlnative
35
36SYSTEMD_SERVICE_${PN} = "openwsmand.service"
37SYSTEMD_AUTO_ENABLE = "disable"
38
39LDFLAGS_append = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', " -fuse-ld=bfd ", '', d)}"
40
41EXTRA_OECMAKE = "-DBUILD_BINDINGS=NO \
42 -DBUILD_LIBCIM=NO \
43 -DBUILD_PERL=YES \
44 -DBUILD_PYTHON3=YES \
45 -DBUILD_PYTHON=NO \
46 -DCMAKE_INSTALL_PREFIX=${prefix} \
47 -DLIB=${baselib} \
48 "
49
50do_configure_prepend() {
51 export STAGING_INCDIR=${STAGING_INCDIR}
52 export STAGING_LIBDIR=${STAGING_LIBDIR}
53}
54
55do_install_append() {
56 install -d ${D}/${sysconfdir}/init.d
57 install -m 755 ${B}/etc/init/openwsmand.sh ${D}/${sysconfdir}/init.d/openwsmand
58 ln -sf ${sysconfdir}/init.d/openwsmand ${D}/${sbindir}/rcopenwsmand
59 chmod 755 ${D}/${sysconfdir}/openwsman/owsmangencert.sh
60 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
61 install -d ${D}/${systemd_unitdir}/system
62 install -m 644 ${WORKDIR}/openwsmand.service ${D}/${systemd_unitdir}/system
63
64 sed -i -e 's,@SBINDIR@,${sbindir},g' ${D}${systemd_unitdir}/system/openwsmand.service
65 sed -i -e 's,@SYSCONFDIR@,${sysconfdir},g' ${D}${systemd_unitdir}/system/openwsmand.service
66 sed -i -e 's,@LOCALSTATEDIR@,${localstatedir},g' ${D}${systemd_unitdir}/system/openwsmand.service
67 fi
68}
69
70FILES_${PN}-dbg += "${libdir}/openwsman/plugins/.debug/ \
71 ${libdir}/openwsman/authenticators/.debug/ \
72 "
73
74INSANE_SKIP_${PN} = "dev-so"
75RDEPENDS_${PN} = "ruby"