blob: c5eaf425ce5a9d8ec34ee4ae8376c0a2d8cebc37 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "OpenGL frontend to Freetype 2"
2HOMEPAGE = "https://sourceforge.net/projects/ftgl/"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://COPYING;md5=527a83e92c7bf363025380eec05df6e4"
5
6inherit autotools pkgconfig distro_features_check
7
8REQUIRED_DISTRO_FEATURES = "opengl"
9
10DEPENDS += " \
11 freetype \
12 freeglut \
13"
14
15SRC_URI = " \
16 ${SOURCEFORGE_MIRROR}/${BPN}/${BPN}-${PV}.tar.bz2 \
17 file://0001-use-pkg-config-to-find-freetype2.patch \
18 file://0002-Makefile.am-remove-useless-and-breaking-code.patch \
19 file://0001-Explicit-typecast-to-avoid-implicit-double-to-float-.patch \
20"
21SRC_URI[md5sum] = "c7879018cde844059495b3029b0b6503"
22SRC_URI[sha256sum] = "521ff7bd62c459ff5372e269c223e2a6107a6a99a36afdc2ae634a973af70c59"
23
24S = "${WORKDIR}/ftgl-2.1.3~rc5"
25
26# undefined reference to symbol 'sin@@GLIBC_2.4'
27CFLAGS += "-lm"