blob: 8f1d34b5877c176339b8e3810cb0c90ba7f05a5d [file] [log] [blame]
Kun Yi733887b2019-03-08 11:43:27 -08001HOMEPAGE = "http://github.com/openbmc/phosphor-ipmi-blobs-binarystore"
2SUMMARY = "BMC Generic Binary Blob Store via OEM IPMI Blob Transport"
3DESCRIPTION = "This package provides a read/write/serialize abstraction for storing binary data through IPMI blobs"
4PR = "r1"
5PV = "1.0+git${SRCPV}"
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
8
9inherit autotools pkgconfig
10inherit obmc-phosphor-ipmiprovider-symlink
11
12DEPENDS += "autoconf-archive-native"
13DEPENDS += "phosphor-ipmi-blobs"
14DEPENDS += "phosphor-logging"
15DEPENDS += "protobuf-native"
16DEPENDS += "protobuf"
17
18S = "${WORKDIR}/git"
19SRC_URI = "git://github.com/openbmc/phosphor-ipmi-blobs-binarystore"
Andrew Geissler0f108212020-09-03 22:21:20 +000020SRCREV = "c3abe753fca211f49eb68f7d34e37bfc9eb5d4c4"
Kun Yi733887b2019-03-08 11:43:27 -080021
22FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
23FILES_${PN}_append = " ${libdir}/blob-ipmid/lib*${SOLIBS}"
24FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
25
26BLOBIPMI_PROVIDER_LIBRARY += "libbinarystore.so"