blob: 700622d593f99c55534d745ad2afae93b977c702 [file] [log] [blame]
Andrew Jeffery858c9712021-05-04 12:46:46 +09301SUMMARY = "Debug trigger"
2DESCRIPTION = "Forcibly crash an unresponsive system to collect debug data"
3HOMEPAGE = "https://github.com/openbmc/debug-trigger"
4
Patrick Williamsbb99d222022-01-24 15:55:09 -06005SRC_URI = "git://github.com/openbmc/debug-trigger;branch=master;protocol=https"
Andrew Jeffery858c9712021-05-04 12:46:46 +09306
7LICENSE = "Apache-2.0"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
9
10S = "${WORKDIR}/git"
11
12inherit meson
13inherit pkgconfig
14inherit systemd
15
16PR = "r1"
17PV = "0.1+git${SRCPV}"
Andrew Geissler516d9f62023-12-21 23:30:05 -060018SRCREV = "92eb22223d414940cc09af7c029192473d1d385e"
Andrew Jeffery858c9712021-05-04 12:46:46 +093019
20PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
21
22DEBUG_TRIGGERS ?= ""
23
24PACKAGECONFIG[systemd] = " \
25 -Dsystemd=true, \
26 -Dsystemd=false, \
27 systemd"
28
29PACKAGECONFIG[triggers] = " \
30 -Dtriggers=${DEBUG_TRIGGERS}, \
31 -Dtriggers=[], \
32 systemd udev"
33
Patrick Williams12fc9392021-08-06 09:16:53 -050034SYSTEMD_SERVICE:${PN} += "debug-trigger@.service"