Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | SUMMARY = "GNOME XSLT library" |
| 2 | HOMEPAGE = "http://xmlsoft.org/XSLT/" |
| 3 | BUGTRACKER = "https://bugzilla.gnome.org/" |
| 4 | |
| 5 | LICENSE = "MIT" |
| 6 | LIC_FILES_CHKSUM = "file://Copyright;md5=0cd9a07afbeb24026c9b03aecfeba458" |
| 7 | |
| 8 | SECTION = "libs" |
| 9 | DEPENDS = "libxml2" |
| 10 | |
| 11 | SRC_URI = "http://xmlsoft.org/sources/libxslt-${PV}.tar.gz" |
| 12 | SRC_URI[md5sum] = "1fc72f98e98bf4443f1651165f3aa146" |
| 13 | SRC_URI[sha256sum] = "526ecd0abaf4a7789041622c3950c0e7f2c4c8835471515fd77eec684a355460" |
| 14 | |
| 15 | UPSTREAM_CHECK_REGEX = "libxslt-(?P<pver>\d+(\.\d+)+)\.tar" |
| 16 | |
| 17 | S = "${WORKDIR}/libxslt-${PV}" |
| 18 | |
| 19 | BINCONFIG = "${bindir}/xslt-config" |
| 20 | |
| 21 | inherit autotools pkgconfig binconfig-disabled lib_package |
| 22 | |
| 23 | # We don't DEPEND on binutils for ansidecl.h so ensure we don't use the header |
| 24 | do_configure_prepend () { |
| 25 | sed -i -e 's/ansidecl.h//' ${S}/configure.ac |
| 26 | |
| 27 | # The timestamps in the 1.1.28 tarball are messed up causing this file to |
| 28 | # appear out of date. Touch it so that we don't try to regenerate it. |
| 29 | touch ${S}/doc/xsltproc.1 |
| 30 | } |
| 31 | |
| 32 | EXTRA_OECONF = "--without-python --without-debug --without-mem-debug --without-crypto" |
| 33 | # older versions of this recipe had ${PN}-utils |
| 34 | RPROVIDES_${PN}-bin += "${PN}-utils" |
| 35 | RCONFLICTS_${PN}-bin += "${PN}-utils" |
| 36 | RREPLACES_${PN}-bin += "${PN}-utils" |
| 37 | |
| 38 | |
| 39 | do_install_append_class-native () { |
| 40 | create_wrapper ${D}/${bindir}/xsltproc XML_CATALOG_FILES=${sysconfdir}/xml/catalog.xml |
| 41 | } |
| 42 | |
| 43 | FILES_${PN} += "${libdir}/libxslt-plugins" |
| 44 | FILES_${PN}-dev += "${libdir}/xsltConf.sh" |
| 45 | |
| 46 | BBCLASSEXTEND = "native nativesdk" |