blob: 6f09002f5589dbdff74088e603bed2115abc3a02 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Real-time file compressor"
2DESCRIPTION = "lzop is a compression utility which is designed to be a companion to gzip. \n\
3It is based on the LZO data compression library and its main advantages over \n\
4gzip are much higher compression and decompression speed at the cost of some \n\
5compression ratio. The lzop compression utility was designed with the goals \n\
6of reliability, speed, portability and with reasonable drop-in compatibility \n\
7to gzip."
8DEPENDS += "lzo"
9
10LICENSE = "GPLv2+"
11LIC_FILES_CHKSUM = "file://COPYING;md5=dfeaf3dc4beef4f5a7bdbc35b197f39e \
12 file://src/lzop.c;beginline=5;endline=21;md5=6797bd3ed0a1a49327b7ebf9366ebd86"
13
14SRC_URI = "http://www.lzop.org/download/${BP}.tar.gz \
15 file://acinclude.m4 \
16 file://x32_abi_miniacc_h.patch \
17 file://0001-use-static-inlines-as-the-external-inline-definition.patch \
Patrick Williamsc0f7c042017-02-23 20:41:17 -060018 file://lzop-1.03-gcc6.patch \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050019 "
20SRC_URI[md5sum] = "006c5e27fb78cdd14a628fdfa5aa1905"
21SRC_URI[sha256sum] = "c1425b8c77d49f5a679d5a126c90ea6ad99585a55e335a613cae59e909dbb2c9"
22
23inherit autotools
24
Patrick Williamsc0f7c042017-02-23 20:41:17 -060025do_configure_prepend () {
26 install -Dm 0644 ${WORKDIR}/acinclude.m4 ${S}/acinclude.m4
Patrick Williamsc124f4f2015-09-15 14:41:29 -050027}
28
Brad Bishop6e60e8b2018-02-01 10:27:11 -050029BBCLASSEXTEND = "native nativesdk"