blob: 5ca2dda3233c099c22dcdecff2788932347e3750 [file] [log] [blame]
Brad Bishop0f291cc2019-09-01 15:16:57 -04001DESCRIPTION = "Tiny XML Library"
2LICENSE = "Apache-2.0"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
4HOMEPAGE = "https://www.msweet.org/mxml/"
5BUGTRACKER = "https://github.com/michaelrsweet/mxml/issues"
6
7SRC_URI = "git://github.com/michaelrsweet/mxml.git"
8SRCREV = "c7755b6992a2afdd34dde47fc9be97f1237cfded"
9S = "${WORKDIR}/git"
10
11inherit autotools
12
13PACKAGECONFIG ??= "threads"
14PACKAGECONFIG[threads] = "--enable-threads,--disable-threads"
15
16# Package does not support out of tree builds.
17B = "${S}"
18
19# MXML uses autotools but it explicitly states it does not support autoheader.
20EXTRA_AUTORECONF = "--exclude=autopoint,autoheader"
21
22do_configure_prepend() {
23 # Respect optimization CFLAGS specified by OE.
24 sed -e 's/-Os -g//' -i ${S}/configure.ac
25
26 # Enable verbose compilation output. This is required for extra QA checks to work.
27 sed -e '/.SILENT:/d' -i ${S}/Makefile.in
28}
29
30do_install() {
31 # Package uses DSTROOT instread of standard DESTDIR to specify install location.
32 oe_runmake install DSTROOT=${D}
33}