Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | DESCRIPTION = "CxxTest is a unit testing framework for C++ that is similar in spirit to JUnit, CppUnit, and xUnit." |
| 2 | HOMEPAGE = "http://cxxtest.com/" |
| 3 | SECTION = "devel" |
| 4 | LICENSE = "LGPL-2.0" |
| 5 | LIC_FILES_CHKSUM = "file://${WORKDIR}/cxxtest-${PV}/COPYING;md5=e6a600fd5e1d9cbde2d983680233ad02" |
| 6 | |
| 7 | SRC_URI = "http://downloads.sourceforge.net/project/cxxtest/cxxtest/${PV}/cxxtest-${PV}.tar.gz" |
| 8 | SRC_URI[md5sum] = "c3cc3355e2ac64e34c215f28e44cfcec" |
| 9 | SRC_URI[sha256sum] = "1c154fef91c65dbf1cd4519af7ade70a61d85a923b6e0c0b007dc7f4895cf7d8" |
| 10 | |
| 11 | S = "${WORKDIR}/cxxtest-${PV}/python" |
| 12 | |
| 13 | inherit distutils |
| 14 | |
| 15 | do_install_append() { |
| 16 | install -d ${D}${includedir} |
| 17 | cp -a ../cxxtest ${D}${includedir} |
| 18 | sed '1c\ |
| 19 | #!/usr/bin/env python' -i ${D}${bindir}/cxxtestgen |
| 20 | } |
| 21 | |
| 22 | BBCLASSEXTEND = "native nativesdk" |