blob: 8f1fe7f41c6416a001ad9d0c75435c80c0d62daa [file] [log] [blame]
Brad Bishop0f547b12017-05-31 14:08:33 -04001SUMMARY = "Phosphor DBus Monitor"
2DESCRIPTION = "Phosphor DBus Monitor is a general purpose DBus application \
3that watches DBus traffic for events and takes actions based on those events."
4PR = "r1"
5
6HOMEPAGE = "http://github.com/openbmc/phosphor-dbus-monitor"
7LICENSE = "Apache-2.0"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
9SRC_URI = "git://github.com/openbmc/phosphor-dbus-monitor"
10SRCREV = "1ada93be00378c94ff14bec8c2c7f5bbd85f72b0"
11
12inherit autotools \
13 pkgconfig \
14 pythonnative \
15 phosphor-dbus-monitor \
16 obmc-phosphor-systemd
17
18DEPENDS += " \
19 ${PN}-config-native \
20 phosphor-logging \
21 autoconf-archive-native \
22 gtest \
23 "
24RDEPENDS_${PN} += " \
25 sdbusplus \
26 phosphor-dbus-interfaces \
27 phosphor-logging \
28 "
29
30S = "${WORKDIR}/git"
31
32EXTRA_OECONF = " \
33 YAML_PATH=${STAGING_DIR_NATIVE}${config_dir} \
34 "