blob: aec1ebf7b2ed6cae4d284a52346d24f805f3a207 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "The GIMP is the GNU Image Manipulation Program"
2HOMEPAGE = "http://www.gimp.org"
3SECTION = "x11/graphics"
4LICENSE = "GPLv3"
5LIC_FILES_CHKSUM = "file://COPYING;md5=c678957b0c8e964aa6c70fd77641a71e"
6
7DEPENDS = " \
8 gdk-pixbuf-native \
9 intltool-native \
10 libxslt-native \
11 gegl-native \
12 dbus-glib \
13 gtk+ \
14 babl \
15 gegl \
16 libmypaint \
17 mypaint-brushes-1.0 \
18 gexiv2 \
19 jpeg \
20 libpng \
21 libexif \
22 tiff \
23 lcms \
24 poppler \
25 poppler-data \
26 jasper \
27 bzip2 \
28 libgudev \
29 libmng \
30 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libxmu libxpm', '', d)} \
31"
32DEPENDS_append_libc-musl = " libexecinfo"
33
34inherit features_check gnomebase gtk-icon-cache gtk-doc mime-xdg
35
36REQUIRED_DISTRO_FEATURES = "x11"
37
38SHPV = "${@gnome_verdir("${PV}")}"
39
40SRC_URI = "https://download.gimp.org/pub/${BPN}/v${SHPV}/${BP}.tar.bz2"
Andrew Geisslerbbbd5f42020-10-30 15:42:48 -050041SRC_URI[sha256sum] = "2db84b57f3778d80b3466d7c21a21d22e315c7b062de2883cbaaeda9a0f618bb"
Andrew Geissler82c905d2020-04-13 13:39:40 -050042
43EXTRA_OECONF = "--disable-python \
44 --without-webkit \
45 --without-wmf"
46
47EXTRA_OECONF_append_libc-musl_mipsarch = " --disable-vector-icons"
48EXTRA_OECONF_append_toolchain-clang_arm = " --disable-vector-icons"
49
50do_configure_append() {
51 find ${B} -name Makefile | xargs sed -i s:'-I$(includedir)':'-I.':g
52 find ${B} -name Makefile | xargs sed -i s:'-I/usr/include':'-I${STAGING_INCDIR}':g
53}
54
55do_compile_prepend() {
56 # Let native babl/gegl find their plugins
57 export BABL_PATH=`find ${STAGING_LIBDIR_NATIVE} -maxdepth 1 -name 'babl-*'`
58 export GEGL_PATH=`find ${STAGING_LIBDIR_NATIVE} -maxdepth 1 -name 'gegl-*'`
59}
60
61FILES_${PN} += "${datadir}/metainfo"
62
63RDEPENDS_${PN} += "mypaint-brushes-1.0"