blob: 25709a1176431ba77528a41130b97798e83ccafe [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "matplotlib: plotting with Python"
2DESCRIPTION = "\
3Matplotlib is a Python 2D plotting library which produces \
4publication-quality figures in a variety of hardcopy formats \
5and interactive environments across platforms."
6HOMEPAGE = "https://github.com/matplotlib/matplotlib"
7SECTION = "devel/python"
8LICENSE = "PSF"
9LIC_FILES_CHKSUM = "\
Andrew Geisslerd688a012020-09-18 13:36:00 -050010 file://setup.py;beginline=259;endline=259;md5=e0ef37de7122ce842bcd1fb54482b353 \
Andrew Geissler82c905d2020-04-13 13:39:40 -050011 file://LICENSE/LICENSE;md5=afec61498aa5f0c45936687da9a53d74 \
12"
13DEPENDS = "\
14 freetype \
15 libpng \
16 python3-numpy-native \
17 python3-dateutil-native \
18 python3-pytz-native \
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050019 python3-certifi-native \
Andrew Geissler82c905d2020-04-13 13:39:40 -050020"
21
Andrew Geisslerd688a012020-09-18 13:36:00 -050022SRC_URI[md5sum] = "a85791908e78818bd425ba9ab38500fa"
23SRC_URI[sha256sum] = "3d2edbf59367f03cd9daf42939ca06383a7d7803e3993eb5ff1bee8e8a3fbb6b"
Andrew Geissler82c905d2020-04-13 13:39:40 -050024
25inherit pypi setuptools3 pkgconfig
26
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050027# LTO with clang needs lld
28LDFLAGS_append_toolchain-clang = " -fuse-ld=lld"
Andrew Geissler72956ed2021-01-08 16:11:14 -060029LDFLAGS_remove_toolchain-clang_mips = "-fuse-ld=lld"
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050030
Andrew Geissler82c905d2020-04-13 13:39:40 -050031RDEPENDS_${PN} = "\
32 freetype \
33 libpng \
34 python3-numpy \
35 python3-pyparsing \
36 python3-cycler \
37 python3-dateutil \
38 python3-kiwisolver \
39 python3-pytz \
40"
41
Andrew Geissler4b7c1152020-11-30 19:55:29 -060042ENABLELTO_toolchain-clang_riscv64 = "echo enable_lto = False >> ${S}/setup.cfg"
43ENABLELTO_toolchain-clang_riscv32 = "echo enable_lto = False >> ${S}/setup.cfg"
Andrew Geissler72956ed2021-01-08 16:11:14 -060044ENABLELTO_toolchain-clang_mips = "echo enable_lto = False >> ${S}/setup.cfg"
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050045do_compile_prepend() {
46 echo [libs] > ${S}/setup.cfg
47 echo system_freetype = true >> ${S}/setup.cfg
Andrew Geissler4b7c1152020-11-30 19:55:29 -060048 ${ENABLELTO}
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050049}
50
Andrew Geissler82c905d2020-04-13 13:39:40 -050051BBCLASSEXTEND = "native"