blob: 0fd040d418bc46e7530c6cecc468b6f31d2b897b [file] [log] [blame]
Alexander Filippov126f6672018-11-28 11:32:04 +03001SUMMARY = "Init BMC MAC address"
2DESCRIPTION = "Setup BMC MAC address read from VPD"
3PR = "r1"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://${OPENPOWERBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
6
7inherit allarch systemd
8
9RDEPENDS_${PN} = "${VIRTUAL-RUNTIME_base-utils}"
10
11SYSTEMD_SERVICE_${PN} = "first-boot-set-mac@.service"
12
13SRC_URI = "file://${PN}.sh file://${PN}@.service"
14
15S = "${WORKDIR}"
16do_install() {
17 install -d ${D}${bindir} ${D}${systemd_system_unitdir}
18 install ${PN}.sh ${D}${bindir}/
19 install -m 644 ${PN}@.service ${D}${systemd_system_unitdir}/
20}