blob: afd26fa1c4d358ce1b6dd3f42ecba8b298ea0f53 [file] [log] [blame]
Brad Bishope42b3e32020-01-15 22:08:42 -05001# Copyright (C) 2020 Jens Rehsack <sno@netbsd.org>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "A module to implement some of AutoConf macros in pure perl"
5DESCRIPTION = "Config::AutoConf is intended to provide the same opportunities to Perl \
6developers as GNU Autoconf <http://www.gnu.org/software/autoconf/> does for \
7Shell developers."
8
9HOMEPAGE= "https://metacpan.org/release/Config-AutoConf"
10
11SECTION = "libs"
12LICENSE = "Artistic-1.0 | GPL-1.0+"
13
14LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Artistic-1.0;md5=cda03bbdc3c1951996392b872397b798 \
15file://${COMMON_LICENSE_DIR}/GPL-1.0;md5=e9e36a9de734199567a4d769498f743d"
16
17SRC_URI = "${CPAN_MIRROR}/authors/id/R/RE/REHSACK/Config-AutoConf-${PV}.tar.gz"
18
19SRC_URI[md5sum] = "0bea721ad3996e20324b84b3b924ec71"
20SRC_URI[sha256sum] = "33c930feec3003de251ca222abe8bbeb74610ad07f65fc16f27d74d195eeab34"
21RDEPENDS_${PN} += "libcapture-tiny-perl"
22RDEPENDS_${PN} += "perl-module-base"
23RDEPENDS_${PN} += "perl-module-carp"
24RDEPENDS_${PN} += "perl-module-config"
25RDEPENDS_${PN} += "perl-module-constant"
26RDEPENDS_${PN} += "perl-module-file-basename"
27RDEPENDS_${PN} += "perl-module-file-spec"
28RDEPENDS_${PN} += "perl-module-file-temp"
29RDEPENDS_${PN} += "perl-module-extutils-cbuilder"
30RDEPENDS_${PN} += "perl-module-extutils-cbuilder-platform-unix"
31RDEPENDS_${PN} += "perl-module-scalar-util"
32RDEPENDS_${PN} += "perl-module-strict"
33RDEPENDS_${PN} += "perl-module-text-parsewords"
34RDEPENDS_${PN} += "perl-module-warnings"
35RRECOMMENDS_${PN} += "libfile-slurper-perl"
36
37S = "${WORKDIR}/Config-AutoConf-${PV}"
38
Andrew Geissler82c905d2020-04-13 13:39:40 -050039inherit cpan ptest-perl
Brad Bishope42b3e32020-01-15 22:08:42 -050040
41BBCLASSEXTEND = "native nativesdk"