blob: ffc343b93101dc7833ee279f5f38d20bd677697b [file] [log] [blame]
Matt Spinlerb640b0b2018-06-21 14:23:47 -05001SUMMARY = "Copy error yaml files to known path for elog parsing"
2PR = "r1"
Patrick Venturef5b81bf2018-10-26 08:57:14 -07003PV = "1.0+git${SRCPV}"
Matt Spinlerb640b0b2018-06-21 14:23:47 -05004LICENSE = "Apache-2.0"
Brad Bishop6f3f0aa2019-09-13 12:14:05 -04005LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
Matt Spinlerb640b0b2018-06-21 14:23:47 -05006
Matt Spinlerb640b0b2018-06-21 14:23:47 -05007inherit phosphor-dbus-yaml
Joseph Reynolds79809ea2021-02-26 15:37:31 -06008inherit native
Matt Spinlerb640b0b2018-06-21 14:23:47 -05009
10require phosphor-software-manager.inc
11
12S = "${WORKDIR}/git"
13
Patrick Williams12fc9392021-08-06 09:16:53 -050014do_install:append() {
Matt Spinlerb640b0b2018-06-21 14:23:47 -050015 SRC=${S}/xyz/openbmc_project/Software/
16 DEST=${D}${yaml_dir}/xyz/openbmc_project/Software/
17 install -d ${DEST}
18 install ${SRC}/*.errors.yaml ${DEST}
19 install ${SRC}/*.metadata.yaml ${DEST}
20}