blob: 4cc8b2769c27914f5e681f4f70bbd2ba82ac38fd [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001
2inherit python-dir
3
4PYTHON="${STAGING_BINDIR_NATIVE}/${PYTHON_PN}-native/${PYTHON_PN}"
5# PYTHON_EXECUTABLE is used by cmake
6PYTHON_EXECUTABLE="${PYTHON}"
7EXTRANATIVEPATH += "${PYTHON_PN}-native"
Patrick Williamsc0f7c042017-02-23 20:41:17 -06008DEPENDS_append = " ${PYTHON_PN}-native "
9
10# python-config and other scripts are using distutils modules
11# which we patch to access these variables
12export STAGING_INCDIR
13export STAGING_LIBDIR
14
Brad Bishopd7bf8c12018-02-25 22:55:05 -050015# suppress host user's site-packages dirs.
16export PYTHONNOUSERSITE = "1"
17
Patrick Williamsc0f7c042017-02-23 20:41:17 -060018# autoconf macros will use their internal default preference otherwise
19export PYTHON