blob: a337076dc89489a0f12841c31e5f18be76716106 [file] [log] [blame]
Richard Marian Thomaiyar14fddef2018-07-13 23:55:56 +05301DESCRIPTION = "A small image for building meta-security packages"
2
3IMAGE_FEATURES += "ssh-server-openssh"
4
5IMAGE_INSTALL = "\
6 packagegroup-base \
7 packagegroup-core-boot \
8 ${@bb.utils.contains('MACHINE_FEATURES', 'tpm', 'packagegroup-security-tpm', '', d)} \
9 ${@bb.utils.contains('MACHINE_FEATURES', 'tpm2', 'packagegroup-security-tpm2', '', d)} \
10 os-release \
11 ${CORE_IMAGE_EXTRA_INSTALL}"
12
13IMAGE_LINGUAS ?= " "
14
15LICENSE = "MIT"
16
17inherit core-image
18
19export IMAGE_BASENAME = "security-tpm-image"