blob: f7859a71c41bb8f8c46c4767362e6b9c15bfc1a1 [file] [log] [blame]
Richard Marian Thomaiyar14fddef2018-07-13 23:55:56 +05301SUMMARY = "Exports a gssapi interface which calls other gssapi libraries"
2DESCRIPTION = "\
3This library exports a gssapi interface, but does not implement any gssapi \
4mechanisms itself; instead it calls gssapi routines in other libraries, \
5depending on the mechanism. \
6"
7
8HOMEPAGE = "http://www.citi.umich.edu/projects/nfsv4/linux/"
9SECTION = "libs"
10
11LICENSE = "BSD-3-Clause | HPND"
12
13#Copyright (c) 1996, by Sun Microsystems, Inc. HPND
14#Copyright (c) 2007 The Regents of the University of Michigan. BSD-3-Clause
15#Copyright 1995 by the Massachusetts Institute of Technology. HPND without Disclaimer
16#Copyright 1993 by OpenVision Technologies, Inc. HPND
17LIC_FILES_CHKSUM = "file://COPYING;md5=56871e72a5c475289c0d5e4ba3f2ee3a \
18 file://src/g_accept_sec_context.c;beginline=3;endline=23;md5=8a7f4017cb7f4be49f8981cb8c472690 \
19 file://src/g_ccache_name.c;beginline=1;endline=32;md5=208d4de05d5c8273963a8332f084faa7 \
20 file://src/oid_ops.c;beginline=1;endline=26;md5=1f194d148b396972da26759a8ec399f0 \
21 file://src/oid_ops.c;beginline=378;endline=398;md5=e02c165cb8383e950214baca2fbd664b \
22"
23
24SRC_URI = "http://www.citi.umich.edu/projects/nfsv4/linux/${BPN}/${BP}.tar.gz \
25 file://libgssglue-canon-name.patch \
26 file://libgssglue-gss-inq-cred.patch \
27 file://libgssglue-mglueP.patch \
28 file://libgssglue-g-initialize.patch \
29 file://libgssglue-fix-CVE-2011-2709.patch \
30"
31
32SRC_URI[md5sum] = "088797f3180702fa54e786496b32e750"
33SRC_URI[sha256sum] = "3f791a75502ba723e5e85e41e5e0c711bb89e2716b7c0ec6e74bd1df6739043a"
34
35# gssglue can use krb5, spkm3... as gssapi library, configurable
36RRECOMMENDS_${PN} += "krb5"
37
38inherit autotools
39
40do_install_append() {
41 # install some docs
42 install -d -m 0755 ${D}${docdir}/${BPN}
43 install -m 0644 ${S}/AUTHORS ${S}/ChangeLog ${S}/NEWS ${S}/README ${D}${docdir}/${BPN}
44
45 # install the gssapi_mech.conf
46 install -d -m 0755 ${D}${sysconfdir}
47 install -m 0644 ${S}/doc/gssapi_mech.conf ${D}${sysconfdir}
48
49 # change the libgssapi_krb5.so path and name(it is .so.2)
50 sed -i -e "s:/usr/lib/libgssapi_krb5.so:libgssapi_krb5.so.2:" ${D}${sysconfdir}/gssapi_mech.conf
51}