Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | DESCRIPTION = "CGI.pm is a stable, complete and mature solution for processing and preparing \ |
| 2 | HTTP requests and responses. Major features including processing form \ |
| 3 | submissions, file uploads, reading and writing cookies, query string generation \ |
| 4 | and manipulation, and processing and preparing HTTP headers." |
| 5 | HOMEPAGE = "http://search.cpan.org/~leejo/CGI-4.28/lib/CGI.pod" |
| 6 | SECTION = "libs" |
| 7 | LICENSE = "Artistic-2.0 | GPL-2.0" |
| 8 | |
| 9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=415fc49abed2728f9480cd32c8d67beb" |
| 10 | |
| 11 | SRC_URI = "http://search.cpan.org/CPAN/authors/id/L/LE/LEEJO/CGI-${PV}.tar.gz" |
| 12 | |
Andrew Geissler | bffdb3e | 2020-08-21 16:13:29 -0500 | [diff] [blame] | 13 | SRC_URI[md5sum] = "6c7c9d0c272849f3c3c1859cb78962fe" |
| 14 | SRC_URI[sha256sum] = "d8c7a2143352842a9b4962c314ee7e0385273c8b9d8314dcbd04a09c008eef46" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 15 | |
| 16 | S = "${WORKDIR}/CGI-${PV}" |
| 17 | |
| 18 | inherit cpan ptest-perl |
| 19 | |
| 20 | RDEPENDS_${PN} += "\ |
| 21 | libhtml-parser-perl \ |
| 22 | perl-module-base \ |
| 23 | perl-module-deprecate \ |
| 24 | perl-module-if \ |
| 25 | " |
| 26 | |
| 27 | do_install_prepend() { |
| 28 | # requires "-T" (taint) command line option |
| 29 | rm -rf ${B}/t/push.t |
| 30 | rm -rf ${B}/t/utf8.t |
| 31 | # tests building of docs |
| 32 | rm -rf ${B}/t/compiles_pod.t |
| 33 | } |
| 34 | |
| 35 | RDEPENDS_${PN}-ptest += " \ |
| 36 | libtest-deep-perl \ |
| 37 | libtest-warn-perl \ |
| 38 | perl-module-bytes \ |
| 39 | perl-module-file-find \ |
| 40 | perl-module-filehandle \ |
| 41 | perl-module-findbin \ |
| 42 | perl-module-lib \ |
| 43 | perl-module-perlio \ |
| 44 | perl-module-perlio-scalar \ |
| 45 | perl-module-test-more \ |
| 46 | perl-module-utf8 \ |
| 47 | " |
| 48 | |
| 49 | RPROVIDES_${PN} += "perl-module-cgi" |
| 50 | |
| 51 | BBCLASSEXTEND = "native" |