blob: 61ed78b6fe905448f4cf87ec8be3db75fac897df [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001DESCRIPTION = "CGI.pm is a stable, complete and mature solution for processing and preparing \
2HTTP requests and responses. Major features including processing form \
3submissions, file uploads, reading and writing cookies, query string generation \
4and manipulation, and processing and preparing HTTP headers."
5HOMEPAGE = "http://search.cpan.org/~leejo/CGI-4.28/lib/CGI.pod"
6SECTION = "libs"
7LICENSE = "Artistic-2.0 | GPL-2.0"
8
9LIC_FILES_CHKSUM = "file://LICENSE;md5=415fc49abed2728f9480cd32c8d67beb"
10
11SRC_URI = "http://search.cpan.org/CPAN/authors/id/L/LE/LEEJO/CGI-${PV}.tar.gz"
12
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050013SRC_URI[md5sum] = "6c7c9d0c272849f3c3c1859cb78962fe"
14SRC_URI[sha256sum] = "d8c7a2143352842a9b4962c314ee7e0385273c8b9d8314dcbd04a09c008eef46"
Andrew Geissler82c905d2020-04-13 13:39:40 -050015
16S = "${WORKDIR}/CGI-${PV}"
17
18inherit cpan ptest-perl
19
20RDEPENDS_${PN} += "\
21 libhtml-parser-perl \
22 perl-module-base \
23 perl-module-deprecate \
24 perl-module-if \
25"
26
27do_install_prepend() {
28 # requires "-T" (taint) command line option
29 rm -rf ${B}/t/push.t
30 rm -rf ${B}/t/utf8.t
31 # tests building of docs
32 rm -rf ${B}/t/compiles_pod.t
33}
34
35RDEPENDS_${PN}-ptest += " \
36 libtest-deep-perl \
37 libtest-warn-perl \
38 perl-module-bytes \
39 perl-module-file-find \
40 perl-module-filehandle \
41 perl-module-findbin \
42 perl-module-lib \
43 perl-module-perlio \
44 perl-module-perlio-scalar \
45 perl-module-test-more \
46 perl-module-utf8 \
47"
48
49RPROVIDES_${PN} += "perl-module-cgi"
50
51BBCLASSEXTEND = "native"