blob: d334070cdb087fc1bc843d75fae2817e77033717 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Extensible memoizing collections and decorators"
2HOMEPAGE = "https://github.com/tkem/cachetools"
3DESCRIPTION = "This module provides various memoizing \
4collections and decorators, including variants of the \
5Python 3 Standard Library @lru_cache function decorator."
6SECTION = "devel/python"
7
8LICENSE = "MIT"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=2d1e1bf0ccb26126a230c51f997ce362"
10
Andrew Geisslerc87764f2020-06-27 00:16:32 -050011inherit pypi setuptools3 ptest
12
13SRC_URI += " \
14 file://run-ptest \
15"
16
17RDEPENDS_${PN}-ptest += " \
18 ${PYTHON_PN}-pytest \
19"
20
21do_install_ptest() {
22 install -d ${D}${PTEST_PATH}/tests
23 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
24}
Andrew Geissler82c905d2020-04-13 13:39:40 -050025
Andrew Geisslerd221e032020-07-10 16:13:21 -050026SRC_URI[md5sum] = "ae41b69896f49727e1621d279cb72522"
27SRC_URI[sha256sum] = "bbaa39c3dede00175df2dc2b03d0cf18dd2d32a7de7beb68072d13043c9edb20"
Andrew Geissler82c905d2020-04-13 13:39:40 -050028
29BBCLASSEXTEND = "native nativesdk"