blob: 46deeae158c594d4ba7cab5d28a252c92c3fb6a4 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "This module contains functions for converting between Julian dates and calendar dates"
2DESCRIPTION = "A function for converting Gregorian calendar dates to Julian dates, \
3and another function for converting Julian calendar dates to Julian dates are defined. \
4Two functions for the reverse calculations are also defined."
5
6HOMEPAGE = "https://github.com/phn/jdcal"
7LICENSE = "BSD"
8LIC_FILES_CHKSUM = "file://PKG-INFO;md5=bd236e1f590973467a427bb354be0f46"
9
10inherit pypi setuptools3 ptest
11
12SRC_URI[md5sum] = "e05bdb60fa80f25bc60e73e0c6b7c5dc"
13SRC_URI[sha256sum] = "472872e096eb8df219c23f2689fc336668bdb43d194094b5cc1707e1640acfc8"
14
15RDEPENDS_${PN} += "${PYTHON_PN}-compression ${PYTHON_PN}-io ${PYTHON_PN}-pprint ${PYTHON_PN}-shell"
16
17SRC_URI += " \
18 file://run-ptest \
19"
20
21RDEPENDS_${PN}-ptest += " \
22 ${PYTHON_PN}-pytest \
23"
24
25do_install_ptest() {
26 cp -f ${S}/test_jdcal.py ${D}${PTEST_PATH}/
27}