blob: 7e11a67e7f62c3a6e87248f2cb4d186c2a4de3fb [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Powerful and Pythonic XML processing library combining libxml2/libxslt with the ElementTree API."
2DESCRIPTION = "lxml is a Pythonic, mature binding for the libxml2 and \
3libxslt libraries. It provides safe and convenient access to these \
4libraries using the ElementTree API. It extends the ElementTree API \
5significantly to offer support for XPath, RelaxNG, XML Schema, XSLT, \
6C14N and much more."
7HOMEPAGE = "http://codespeak.net/lxml"
8SECTION = "devel/python"
9LICENSE = "BSD & GPLv2 & MIT & PSF"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050010LIC_FILES_CHKSUM = "file://LICENSES.txt;md5=e4c045ebad958ead4b48008f70838403 \
Patrick Williamsb48b7b42016-08-17 15:04:38 -050011 file://doc/licenses/elementtree.txt;md5=eb34d036a6e3d56314ee49a6852ac891 \
12 file://doc/licenses/BSD.txt;md5=700a1fc17f4797d4f2d34970c8ee694b \
13 file://doc/licenses/GPL.txt;md5=94d55d512a9ba36caa9b7df079bae19f \
Brad Bishop19323692019-04-05 15:28:33 -040014 file://src/lxml/isoschematron/resources/rng/iso-schematron.rng;beginline=2;endline=7;md5=fc85684a8dd5fa272c086bceb0d99e10 \
Brad Bishop316dfdd2018-06-25 12:45:53 -040015 file://src/lxml/isoschematron/resources/xsl/iso-schematron-xslt1/iso_schematron_message.xsl;beginline=2;endline=24;md5=cc86b7b2bbc678e13f58ea403eb9929b \
16 file://src/lxml/isoschematron/resources/xsl/RNG2Schtrn.xsl;beginline=2;endline=7;md5=5b03236d293dc3784205542b409d2f53 \
Patrick Williamsb48b7b42016-08-17 15:04:38 -050017 "
18
19DEPENDS += "libxml2 libxslt"
20
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050021SRC_URI[md5sum] = "83ad758eab6c254b3565715967d553a6"
22SRC_URI[sha256sum] = "cdc13a1682b2a6241080745b1953719e7fe0850b40a5c71ca574f090a1391df6"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050023
Andrew Geissler89770b02020-06-13 10:40:47 -050024inherit pypi setuptools3
Patrick Williamsb48b7b42016-08-17 15:04:38 -050025
Brad Bishopc8f47122019-06-24 09:36:18 -040026# {standard input}: Assembler messages:
27# {standard input}:1488805: Error: branch out of range
28DEBUG_OPTIMIZATION_remove_mips = " -Og"
29DEBUG_OPTIMIZATION_append_mips = " -O"
30BUILD_OPTIMIZATION_remove_mips = " -Og"
31BUILD_OPTIMIZATION_append_mips = " -O"
32
33DEBUG_OPTIMIZATION_remove_mipsel = " -Og"
34DEBUG_OPTIMIZATION_append_mipsel = " -O"
35BUILD_OPTIMIZATION_remove_mipsel = " -Og"
36BUILD_OPTIMIZATION_append_mipsel = " -O"
37
Patrick Williamsb48b7b42016-08-17 15:04:38 -050038BBCLASSEXTEND = "native nativesdk"
39
40RDEPENDS_${PN} += "libxml2 libxslt ${PYTHON_PN}-compression"
Andrew Geissler89770b02020-06-13 10:40:47 -050041
42CLEANBROKEN = "1"