blob: e924b0f731ff5056b135724d139d8a9592e224f8 [file] [log] [blame]
Brad Bishopdec060e2019-09-23 08:01:31 -04001DESCRIPTION = "More routines for operating on iterables, beyond itertools"
2HOMEPAGE = "https://github.com/erikrose/more-itertools"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=3396ea30f9d21389d7857719816f83b5"
Brad Bishop87b3cb82019-11-15 16:35:37 -05005
Andrew Geisslerd688a012020-09-18 13:36:00 -05006SRC_URI[md5sum] = "2588b5a7042576b99574779582be9292"
7SRC_URI[sha256sum] = "6f83822ae94818eae2612063a5101a7311e68ae8002005b5e05f03fd74a86a20"
Andrew Geissler82c905d2020-04-13 13:39:40 -05008
Andrew Geissler89770b02020-06-13 10:40:47 -05009inherit pypi setuptools3 ptest
10
11BBCLASSEXTEND = "native nativesdk"
Andrew Geissler82c905d2020-04-13 13:39:40 -050012
13SRC_URI += " \
14 file://run-ptest \
15"
16
17RDEPENDS_${PN}-ptest += " \
18 ${PYTHON_PN}-pytest \
19"
20
21do_install_ptest() {
22 install -d ${D}${PTEST_PATH}/tests
23 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
24}