blob: 697725fd713f8b7f3c2cb9e6a36ba325228e70aa [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001DESCRIPTION = "Twisted is an event-driven networking framework written in Python and licensed under the LGPL. \
2Twisted supports TCP, UDP, SSL/TLS, multicast, Unix sockets, a large number of protocols \
3(including HTTP, NNTP, IMAP, SSH, IRC, FTP, and others), and much more."
4HOMEPAGE = "http://www.twistedmatrix.com"
5
6#twisted/topfiles/NEWS:655: - Relicensed: Now under the MIT license, rather than LGPL.
7LICENSE = "MIT"
Andrew Geisslerc87764f2020-06-27 00:16:32 -05008LIC_FILES_CHKSUM = "file://LICENSE;md5=27ac6d9597237e7e76282edd7a40cd68"
Brad Bishopd7bf8c12018-02-25 22:55:05 -05009
Andrew Geisslerc87764f2020-06-27 00:16:32 -050010SRC_URI[sha256sum] = "d72c55b5d56e176563b91d11952d13b01af8725c623e498db5507b6614fc1e10"
11SRC_URI[md5sum] = "fc16d575730db7d0cddd09fc35af3eea"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050012
13PYPI_PACKAGE = "Twisted"
14PYPI_PACKAGE_EXT = "tar.bz2"
15
Andrew Geisslerc87764f2020-06-27 00:16:32 -050016inherit pypi setuptools3
17
Brad Bishopd7bf8c12018-02-25 22:55:05 -050018do_install_append() {
19 # remove some useless files before packaging
20 find ${D} \( -name "*.bat" -o -name "*.c" -o -name "*.h" \) -exec rm -f {} \;
21}
22
23PACKAGES += "\
24 ${PN}-zsh \
25 ${PN}-test \
26 ${PN}-protocols \
27 ${PN}-conch \
28 ${PN}-mail \
29 ${PN}-names \
30 ${PN}-news \
31 ${PN}-runner \
32 ${PN}-web \
33 ${PN}-words \
34 ${PN}-flow \
35 ${PN}-pair \
36 ${PN}-core \
37"
38
39PACKAGES =+ "\
Brad Bishopd7bf8c12018-02-25 22:55:05 -050040 ${PN}-bin \
41"
42
Brad Bishop316dfdd2018-06-25 12:45:53 -040043DEPENDS += " \
44 ${PYTHON_PN}-incremental-native \
45"
46
Brad Bishopd7bf8c12018-02-25 22:55:05 -050047RDEPENDS_${PN} = "\
48 ${PN}-bin \
49 ${PN}-core \
50 ${PN}-conch \
51 ${PN}-mail \
52 ${PN}-names \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080053 ${PN}-pair \
54 ${PN}-protocols \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050055 ${PN}-runner \
56 ${PN}-web \
57 ${PN}-words \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080058 ${PN}-zsh \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050059"
60
Andrew Geissler82c905d2020-04-13 13:39:40 -050061RDEPENDS_${PN}-core = "${PYTHON_PN}-appdirs \
62 ${PYTHON_PN}-automat \
63 ${PYTHON_PN}-constantly \
Andrew Geisslerc87764f2020-06-27 00:16:32 -050064 ${PYTHON_PN}-core \
Andrew Geissler82c905d2020-04-13 13:39:40 -050065 ${PYTHON_PN}-debugger \
66 ${PYTHON_PN}-hyperlink \
67 ${PYTHON_PN}-incremental \
68 ${PYTHON_PN}-pyhamcrest \
69 ${PYTHON_PN}-pyserial \
70 ${PYTHON_PN}-unixadmin \
71 ${PYTHON_PN}-zopeinterface \
72"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050073RDEPENDS_${PN}-test = "${PN}"
Brad Bishope42b3e32020-01-15 22:08:42 -050074RDEPENDS_${PN}-conch = "${PN}-core ${PN}-protocols ${PYTHON_PN}-bcrypt ${PYTHON_PN}-cryptography ${PYTHON_PN}-pyasn1 ${PYTHON_PN}-pickle"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050075RDEPENDS_${PN}-mail = "${PN}-core ${PN}-protocols"
76RDEPENDS_${PN}-names = "${PN}-core"
77RDEPENDS_${PN}-news = "${PN}-core ${PN}-protocols"
78RDEPENDS_${PN}-runner = "${PN}-core ${PN}-protocols"
79RDEPENDS_${PN}-web += "${PN}-core ${PN}-protocols"
80RDEPENDS_${PN}-words += "${PN}-core"
81RDEPENDS_${PN}-flow += "${PN}-core"
82RDEPENDS_${PN}-pair += "${PN}-core"
83RDEPENDS_${PN}-dbg = "${PN}"
84
85ALLOW_EMPTY_${PN} = "1"
86FILES_${PN} = ""
87
88FILES_${PN}-test = " \
89 ${libdir}/${PYTHON_DIR}/site-packages/twisted/test \
90 ${libdir}/${PYTHON_DIR}/site-packages/twisted/*/test \
91 ${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols/haproxy/test/ \
92"
93
94FILES_${PN}-protocols = " \
95 ${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols/*.py* \
96 ${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols/gps/ \
97 ${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols/mice/ \
98 ${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols/haproxy \
99"
100
101FILES_${PN}-zsh = " \
102 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/zsh \
103 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/zshcomp.* \
104 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/twisted-completion.zsh \
105"
106
107FILES_${PN}-conch = " \
108 ${bindir}/ckeygen \
109 ${bindir}/tkconch \
110 ${bindir}/conch \
111 ${bindir}/conchftp \
112 ${bindir}/cftp \
113 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_conch.py* \
114 ${libdir}/${PYTHON_DIR}/site-packages/twisted/conch \
115"
116
117FILES_${PN}-core = " \
118${bindir}/manhole \
119${bindir}/mktap \
120${bindir}/twistd \
121${bindir}/tap2deb \
122${bindir}/tap2rpm \
123${bindir}/tapconvert \
124${bindir}/tkmktap \
125${bindir}/trial \
126${bindir}/easy_install* \
127${bindir}/pyhtmlizer \
128${libdir}/${PYTHON_DIR}/site-packages/twisted/python/*.so \
129${libdir}/${PYTHON_DIR}/site-packages/twisted/*.py* \
130${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__init__.py* \
131${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/notestplugin.py* \
132${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/testplugin.py* \
133${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_ftp.py* \
134${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_inet.py* \
135${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_manhole.py* \
136${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_portforward.py* \
137${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_socks.py* \
138${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_telnet.py* \
139${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_trial.py* \
140${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/dropin.cache \
141${libdir}/${PYTHON_DIR}/site-packages/twisted/application \
142${libdir}/${PYTHON_DIR}/site-packages/twisted/cred \
143${libdir}/${PYTHON_DIR}/site-packages/twisted/enterprise \
144${libdir}/${PYTHON_DIR}/site-packages/twisted/internet \
145${libdir}/${PYTHON_DIR}/site-packages/twisted/manhole \
146${libdir}/${PYTHON_DIR}/site-packages/twisted/manhole \
147${libdir}/${PYTHON_DIR}/site-packages/twisted/persisted \
148${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols\
149${libdir}/${PYTHON_DIR}/site-packages/twisted/python\
150${libdir}/${PYTHON_DIR}/site-packages/twisted/python/timeoutqueue.py* \
151${libdir}/${PYTHON_DIR}/site-packages/twisted/python/filepath.py* \
152${libdir}/${PYTHON_DIR}/site-packages/twisted/python/dxprofile.py* \
153${libdir}/${PYTHON_DIR}/site-packages/twisted/python/plugin.py* \
154${libdir}/${PYTHON_DIR}/site-packages/twisted/python/htmlizer.py* \
155${libdir}/${PYTHON_DIR}/site-packages/twisted/python/__init__.py* \
156${libdir}/${PYTHON_DIR}/site-packages/twisted/python/dispatch.py* \
157${libdir}/${PYTHON_DIR}/site-packages/twisted/python/hook.py* \
158${libdir}/${PYTHON_DIR}/site-packages/twisted/python/threadpool.py* \
159${libdir}/${PYTHON_DIR}/site-packages/twisted/python/otp.py* \
160${libdir}/${PYTHON_DIR}/site-packages/twisted/python/usage.py* \
161${libdir}/${PYTHON_DIR}/site-packages/twisted/python/roots.py* \
162${libdir}/${PYTHON_DIR}/site-packages/twisted/python/versions.py* \
163${libdir}/${PYTHON_DIR}/site-packages/twisted/python/urlpath.py* \
164${libdir}/${PYTHON_DIR}/site-packages/twisted/python/util.py* \
165${libdir}/${PYTHON_DIR}/site-packages/twisted/python/components.py* \
166${libdir}/${PYTHON_DIR}/site-packages/twisted/python/logfile.py* \
167${libdir}/${PYTHON_DIR}/site-packages/twisted/python/runtime.py* \
168${libdir}/${PYTHON_DIR}/site-packages/twisted/python/reflect.py* \
169${libdir}/${PYTHON_DIR}/site-packages/twisted/python/context.py* \
170${libdir}/${PYTHON_DIR}/site-packages/twisted/python/threadable.py* \
171${libdir}/${PYTHON_DIR}/site-packages/twisted/python/rebuild.py* \
172${libdir}/${PYTHON_DIR}/site-packages/twisted/python/failure.py* \
173${libdir}/${PYTHON_DIR}/site-packages/twisted/python/lockfile.py* \
174${libdir}/${PYTHON_DIR}/site-packages/twisted/python/formmethod.py* \
175${libdir}/${PYTHON_DIR}/site-packages/twisted/python/finalize.py* \
176${libdir}/${PYTHON_DIR}/site-packages/twisted/python/win32.py* \
177${libdir}/${PYTHON_DIR}/site-packages/twisted/python/dist.py* \
178${libdir}/${PYTHON_DIR}/site-packages/twisted/python/shortcut.py* \
179${libdir}/${PYTHON_DIR}/site-packages/twisted/python/zipstream.py* \
180${libdir}/${PYTHON_DIR}/site-packages/twisted/python/release.py* \
181${libdir}/${PYTHON_DIR}/site-packages/twisted/python/syslog.py* \
182${libdir}/${PYTHON_DIR}/site-packages/twisted/python/log.py* \
183${libdir}/${PYTHON_DIR}/site-packages/twisted/python/compat.py* \
184${libdir}/${PYTHON_DIR}/site-packages/twisted/python/zshcomp.py* \
185${libdir}/${PYTHON_DIR}/site-packages/twisted/python/procutils.py* \
186${libdir}/${PYTHON_DIR}/site-packages/twisted/python/text.py* \
187${libdir}/${PYTHON_DIR}/site-packages/twisted/python/_twisted_zsh_stub \
188${libdir}/${PYTHON_DIR}/site-packages/twisted/scripts/ \
189${libdir}/${PYTHON_DIR}/site-packages/twisted/spread/ \
190${libdir}/${PYTHON_DIR}/site-packages/twisted/tap/ \
191${libdir}/${PYTHON_DIR}/site-packages/twisted/trial/ \
192${libdir}/${PYTHON_DIR}/site-packages/twisted/__init__.py* \
193${libdir}/${PYTHON_DIR}/site-packages/twisted/_version.py* \
194${libdir}/${PYTHON_DIR}/site-packages/twisted/copyright.py* \
195${libdir}/${PYTHON_DIR}/site-packages/twisted/im.py* \
196${libdir}/${PYTHON_DIR}/site-packages/twisted/*.py* \
197${libdir}/${PYTHON_DIR}/site-packages/twisted/python/*.py* \
198${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/*.py* \
199${libdir}/${PYTHON_DIR}/site-packages/twisted/topfiles \
200${libdir}/${PYTHON_DIR}/site-packages/Twisted*egg-info \
201${libdir}/${PYTHON_DIR}/site-packages/twisted/logger/ \
202${libdir}/${PYTHON_DIR}/site-packages/twisted/_threads/ \
203${libdir}/${PYTHON_DIR}/site-packages/twisted/positioning/ \
204"
205
206FILES_${PN}-mail = " \
207${bindir}/mailmail \
208${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_mail.py* \
209${libdir}/${PYTHON_DIR}/site-packages/twisted/mail \
210"
211
212FILES_${PN}-names = " \
213${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_names.py* \
214${libdir}/${PYTHON_DIR}/site-packages/twisted/names \
215"
216
217FILES_${PN}-news = " \
218${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_news.py* \
219${libdir}/${PYTHON_DIR}/site-packages/twisted/news \
220"
221
222FILES_${PN}-runner = " \
223${libdir}/site-packages/twisted/runner/portmap.so \
224${libdir}/${PYTHON_DIR}/site-packages/twisted/runner\
225"
226
227FILES_${PN}-web = " \
228${bindir}/websetroot \
229${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_web.py* \
230${libdir}/${PYTHON_DIR}/site-packages/twisted/web\
231"
232
233FILES_${PN}-words = " \
234${bindir}/im \
235${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_words.py* \
236${libdir}/${PYTHON_DIR}/site-packages/twisted/words\
237"
238
239FILES_${PN}-flow = " \
240${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_flow.py* \
241${libdir}/${PYTHON_DIR}/site-packages/twisted/flow \"
242
243FILES_${PN}-pair = " \
244${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_pair.py* \
245${libdir}/${PYTHON_DIR}/site-packages/twisted/pair \
246"
247
248FILES_${PN}-dbg += " \
249${libdir}/${PYTHON_DIR}/site-packages/twisted/*/.debug \
250${libdir}/${PYTHON_DIR}/site-packages/twisted/*/*/.debug \
251"
252
253FILES_${PN}-doc += " \
254 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/_pydoctortemplates/ \
255"
256
Brad Bishop19323692019-04-05 15:28:33 -0400257RDEPENDS_${PN}-src = "${PN}"
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500258FILES_${PN}-src = " \
259 ${libdir}/${PYTHON_DIR}/site-packages/twisted/*.py \
260 ${libdir}/${PYTHON_DIR}/site-packages/twisted/*/*.py \
261 ${libdir}/${PYTHON_DIR}/site-packages/twisted/*/*/*.py \
262"
Brad Bishop19323692019-04-05 15:28:33 -0400263
Andrew Geisslerc87764f2020-06-27 00:16:32 -0500264FILES_${PN}-core_append = " \
265 ${libdir}/${PYTHON_DIR}/site-packages/twisted/__pycache__ \
266 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/__pycache__/*pyc \
267 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/__init__*.pyc \
268 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/notestplugin*.pyc \
269 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/testplugin*.pyc \
270 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_ftp*.pyc \
271 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_inet*.pyc \
272 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_manhole*.pyc \
273 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_portforward*.pyc \
274 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_socks*.pyc \
275 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_telnet*.pyc \
276 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_trial*.pyc \
277 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_core*.pyc \
278 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_qtstub*.pyc \
279 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_reactors*.pyc \
280 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/cred*.pyc \
281 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/dropin*.cache \
282"
283
284FILES_${PN}-names_append = " \
285 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_names*.pyc \
286"
287
288FILES_${PN}-news_append = " \
289 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_news*.pyc \
290"
291
292FILES_${PN}-protocols_append = " \
293 ${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols/__pycache__/*pyc \
294"
295
296FILES_${PN}-conch_append = " \
297 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_conch*.pyc \
298"
299
300FILES_${PN}-lore_append = " \
301 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_lore*.pyc \
302"
303FILES_${PN}-mail_append = " \
304 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_mail*.pyc \
305"
306
307FILES_${PN}-web_append = " \
308 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_web*.pyc \
309"
310
311FILES_${PN}-words_append = " \
312 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_words*.pyc \
313"
314
315FILES_${PN}-flow_append = " \
316 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_flow*.pyc \
317"
318
319FILES_${PN}-pair_append = " \
320 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_pair*.pyc \
321"
322
323FILES_${PN}-runner_append = " \
324 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_runner*.pyc \
325"