blob: e650b57955d1d0cc4800135be8434aa1c1ef015e [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "A 802.1ab implementation (LLDP) to help you locate neighbors of all your equipments"
2SECTION = "net/misc"
3LICENSE = "ISC"
4LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/ISC;md5=f3b90e78ea0cffb20bf5cca7947a896d"
5
6DEPENDS = "libbsd libevent"
7
8SRC_URI = "\
9 http://media.luffy.cx/files/${BPN}/${BPN}-${PV}.tar.gz \
10 file://lldpd.init.d \
11 file://lldpd.default \
Brad Bishop15ae2502019-06-18 21:44:24 -040012 file://0001-priv-include-limits.h-for-PATH_MAX.patch \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050013 "
14
Brad Bishop15ae2502019-06-18 21:44:24 -040015SRC_URI[md5sum] = "04844328f053ee343344d892efb8a00c"
16SRC_URI[sha256sum] = "39fced395168015416bfe78b95414facf066f841f349024433aa20ab54e4c360"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050017
18inherit autotools update-rc.d useradd systemd pkgconfig bash-completion
19
20USERADD_PACKAGES = "${PN}"
21USERADD_PARAM_${PN} = "--system -g lldpd --shell /bin/false lldpd"
22GROUPADD_PARAM_${PN} = "--system lldpd"
23
24EXTRA_OECONF += "--without-embedded-libevent \
25 --disable-oldies \
26 --with-privsep-user=lldpd \
27 --with-privsep-group=lldpd \
28 --with-systemdsystemunitdir=${systemd_system_unitdir} \
29 --without-sysusersdir \
30"
31
32PACKAGECONFIG ??= "cdp fdp edp sonmp lldpmed dot1 dot3"
33PACKAGECONFIG[xml] = "--with-xml,--without-xml,libxm2"
34PACKAGECONFIG[snmp] = "--with-snmp,--without-snmp,net-snmp"
35PACKAGECONFIG[readline] = "--with-readline,--without-readline,readline"
36PACKAGECONFIG[seccomp] = "--with-seccomp,--without-seccomp,libseccomp"
37PACKAGECONFIG[cdp] = "--enable-cdp,--disable-cdp"
38PACKAGECONFIG[fdp] = "--enable-fdp,--disable-fdp"
39PACKAGECONFIG[edp] = "--enable-edp,--disable-edp"
40PACKAGECONFIG[sonmp] = "--enable-sonmp,--disable-sonmp"
41PACKAGECONFIG[lldpmed] = "--enable-lldpmed,--disable-lldpmed"
42PACKAGECONFIG[dot1] = "--enable-dot1,--disable-dot1"
43PACKAGECONFIG[dot3] = "--enable-dot3,--disable-dot3"
44PACKAGECONFIG[custom] = "--enable-custom,--disable-custom"
45
46INITSCRIPT_NAME = "lldpd"
47INITSCRIPT_PARAMS = "defaults"
48
49SYSTEMD_SERVICE_${PN} = "lldpd.service"
50
51do_install_append() {
52 install -Dm 0755 ${WORKDIR}/lldpd.init.d ${D}${sysconfdir}/init.d/lldpd
53 install -Dm 0644 ${WORKDIR}/lldpd.default ${D}${sysconfdir}/default/lldpd
54 # Make an empty configuration file
55 touch ${D}${sysconfdir}/lldpd.conf
56}
57
58PACKAGES =+ "${PN}-zsh-completion"
59
60FILES_${PN} += "${libdir}/sysusers.d"
61RDEPENDS_${PN} += "os-release"
62
63FILES_${PN}-zsh-completion += "${datadir}/zsh/"
64# FIXME: zsh is broken in meta-oe so this cannot be enabled for now
65#RDEPENDS_${PN}-zsh-completion += "zsh"