blob: 0cccebdfcd04878787fc5f7fcb7841152108dc08 [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "OpenSAF is an open source implementation of the SAF AIS specification"
2DESCRIPTION = "OpenSAF is an open source project established to develop a base platform \
3middleware consistent with Service Availability Forum (SA Forum) \
4specifications, under the LGPLv2.1 license. The OpenSAF Foundation was \
5established by leading Communications and Enterprise Computing Companies to \
6facilitate the OpenSAF Project and to accelerate the adoption of the OpenSAF \
7code base in commercial products. \
8The OpenSAF project was launched in mid 2007 and has been under development by \
9an informal group of supporters of the OpenSAF initiative. The OpenSAF \
10Foundation was founded on January 22nd 2008 with Emerson Network Power, \
11Ericsson, Nokia Siemens Networks, HP and Sun Microsystems as founding members."
12HOMEPAGE = "http://www.opensaf.org"
13SECTION = "admin"
14LICENSE = "LGPLv2.1"
15LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=a916467b91076e631dd8edb7424769c7"
16
17DEPENDS = "libxml2 python"
18TOOLCHAIN = "gcc"
19
20SECURITY_CFLAGS = "${SECURITY_NO_PIE_CFLAGS}"
21
22SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/releases/${BPN}-${PV}.tar.gz \
23 file://0001-configure-Pass-linker-specific-options-with-Wl.patch \
24 file://0001-configure-Disable-format-overflow-if-supported-by-gc.patch \
25 file://0001-src-Add-missing-header-limits.h-for-_POSIX_HOST_NAME.patch \
26 file://0001-immpbe_dump.cc-Use-sys-wait.h-instead-of-wait.h.patch \
Brad Bishopc342db32019-05-15 21:57:59 -040027 "
Brad Bishop15ae2502019-06-18 21:44:24 -040028SRC_URI[md5sum] = "4dd1497ccd82d275735853bf0db5c510"
29SRC_URI[sha256sum] = "de42c8dd850990716ca494ca598165cc7a23b5b7f2bc21af5d71a3d971ddd595"
Brad Bishopc342db32019-05-15 21:57:59 -040030
31inherit autotools useradd systemd pkgconfig
32
33USERADD_PACKAGES = "${PN}"
34GROUPADD_PARAM_${PN} = "-f -r opensaf"
35USERADD_PARAM_${PN} = "-r -g opensaf -d ${datadir}/opensaf/ -s ${sbindir}/nologin -c \"OpenSAF\" opensaf"
36
37SYSTEMD_SERVICE_${PN} += "opensafd.service"
38SYSTEMD_AUTO_ENABLE = "disable"
39
40PACKAGECONFIG[systemd] = ",,systemd"
41PACKAGECONFIG[openhpi] = "--with-hpi-interface=B03,,openhpi"
42PACKAGECONFIG[plm] = "--enable-ais-plm,--disable-ais-plm,libvirt openhpi"
43
44PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', ' systemd', '', d)}"
45
46PKGLIBDIR="${libdir}"
47CPPFLAGS += "-Wno-error=stringop-overflow= -Wno-error=stringop-truncation"
48CXXFLAGS += "-Wno-error=stringop-overflow= -Wno-error=stringop-truncation -Wno-error=format-truncation="
49LDFLAGS += "-Wl,--as-needed -latomic -Wl,--no-as-needed"
50
51do_install_append() {
52 cp -av --no-preserve=ownership ${B}/lib/.libs/*.so* ${D}${libdir}
53 rm -fr "${D}${localstatedir}/lock"
54 rm -fr "${D}${localstatedir}/run"
55 rmdir --ignore-fail-on-non-empty "${D}${localstatedir}"
56 rmdir --ignore-fail-on-non-empty "${D}${datadir}/java"
57 if [ ! -d "${D}${sysconfdir}/init.d" ]; then
58 install -d ${D}${sysconfdir}/init.d
59 install -m 0755 ${B}/osaf/services/infrastructure/nid/scripts/opensafd ${D}${sysconfdir}/init.d/
60 fi
61}
62
63FILES_${PN} += "${systemd_unitdir}/system/*.service"
64FILES_${PN}-staticdev += "${PKGLIBDIR}/*.a"
65
66INSANE_SKIP_${PN} = "dev-so"
67
68RDEPENDS_${PN} += "bash python"
69
70# http://errors.yoctoproject.org/Errors/Details/186970/
71EXCLUDE_FROM_WORLD_libc-musl = "1"