blob: af8961e3228474909afd2a3f138699e284f986d2 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001#
2# Copyright (C) 2012 Wind River Systems, Inc.
3#
4SUMMARY = "Provides a wrapper in Python to LDAP"
5DESCRIPTION = "This module provides access to the LDAP \
6(Lightweight Directory Access Protocol) through Python operations \
7instead of C API. The module mainly acts as a wrapper for the \
8OpenLDAP 2.x libraries. Errors will appear as exceptions."
9
10LICENSE = "PSF"
11HOMEPAGE = "http://www.python-ldap.org/"
12DEPENDS = "python openldap cyrus-sasl"
13
14PYPI_PACKAGE = "python-ldap"
15inherit pypi setuptools
16
17LIC_FILES_CHKSUM = "file://LICENCE;md5=36ce9d726d0321b73c1521704d07db1b"
Brad Bishop15ae2502019-06-18 21:44:24 -040018SRC_URI[md5sum] = "fe22522208dc9b06d16eb70f8553eaab"
19SRC_URI[sha256sum] = "7d1c4b15375a533564aad3d3deade789221e450052b21ebb9720fb822eccdb8e"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080020
21do_configure_prepend() {
22 sed -i -e 's:^library_dirs =.*::' setup.cfg
23 sed -i -e 's:^include_dirs =.*:include_dirs = =/usr/include/sasl/:' setup.cfg
24}
25
26RDEPENDS_${PN} = " \
27 ${PYTHON_PN}-pprint \
28 ${PYTHON_PN}-threading \
Brad Bishop15ae2502019-06-18 21:44:24 -040029 ${PYTHON_PN}-pyasn1 \
30 ${PYTHON_PN}-pyasn1-modules \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080031"