blob: 492ade5ae5ba9ad77b1c289339e669286db51c8b [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "A user-mode PPPoE client and server suite for Linux"
2HOMEPAGE = "http://www.roaringpenguin.com/products/pppoe"
3SECTION = "net"
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://doc/LICENSE;md5=a194eaefae2be54ee3221339b10d0581"
6
7PR = "r10"
8
Brad Bishop15ae2502019-06-18 21:44:24 -04009SRC_URI = "https://dianne.skoll.ca/projects/rp-pppoe/download/rp-pppoe-${PV}.tar.gz \
Patrick Williamsb48b7b42016-08-17 15:04:38 -050010 file://top-autoconf.patch \
11 file://configure_in_cross.patch \
Patrick Williamsb48b7b42016-08-17 15:04:38 -050012 file://update-config.patch \
13 file://dont-swallow-errors.patch \
14 file://discard-use-of-dnl-in-Makefile.am.patch \
15 file://configure.patch \
16 file://pppoe-server.default \
17 file://pppoe-server.init \
18 file://configure.in-Error-fix.patch \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050019 file://pppoe-server.service \
20 file://0001-ppoe-Dont-include-linux-if_ether.h.patch \
21 file://0002-Enable-support-for-the-kernel-module.patch \
22 "
Patrick Williamsb48b7b42016-08-17 15:04:38 -050023
Brad Bishop15ae2502019-06-18 21:44:24 -040024SRC_URI[md5sum] = "ec9dccd9a367a1f71f2dc81069796dd8"
25SRC_URI[sha256sum] = "8cd6bc71ba46bd5f6eb4daf60220ccdcd991a8525111dee466501b1b9717e676"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050026
27inherit autotools-brokensep update-rc.d systemd
28
29do_install_append() {
30 install -d ${D}${systemd_unitdir}/system
31 install -m 0644 ${WORKDIR}/pppoe-server.service ${D}${systemd_unitdir}/system
32 sed -i -e 's#@SYSCONFDIR@#${sysconfdir}#g' ${D}${systemd_unitdir}/system/pppoe-server.service
33 sed -i -e 's#@SBINDIR@#${sbindir}#g' ${D}${systemd_unitdir}/system/pppoe-server.service
34 install -d ${D}${datadir}/doc/${PN}
35 if [ -f ${D}${datadir}/doc/README ]; then
36 mv ${D}${datadir}/doc/README ${D}${datadir}/doc/${PN}/
37 fi
38}
39
40do_install() {
41 # Install init script and default settings
42 install -m 0755 -d ${D}${sysconfdir}/default ${D}${sysconfdir}/init.d
43 install -m 0644 ${WORKDIR}/pppoe-server.default ${D}${sysconfdir}/default/pppoe-server
44 install -m 0755 ${WORKDIR}/pppoe-server.init ${D}${sysconfdir}/init.d/pppoe-server
45 # Install
46 oe_runmake -C ${S} DESTDIR=${D} docdir=${docdir} install
47 chmod 4755 ${D}${sbindir}/pppoe
48}
49
50SYSTEMD_PACKAGES = "${PN}-server"
51SYSTEMD_SERVICE_${PN}-server = "pppoe-server.service"
52SYSTEMD_AUTO_ENABLE = "disable"
53# Insert server package before main package
54PACKAGES = "${PN}-dbg ${PN}-server ${PN}-relay ${PN}-sniff ${PN} ${PN}-doc"
55
56FILES_${PN}-server = "${sysconfdir}/default/pppoe-server \
57 ${sysconfdir}/init.d/pppoe-server \
58 ${sbindir}/pppoe-server \
59 ${sysconfdir}/ppp/pppoe-server-options"
60FILES_${PN}-relay = "${sbindir}/pppoe-relay"
61FILES_${PN}-sniff = "${sbindir}/pppoe-sniff"
62
63CONFFILES_${PN} = "${sysconfdir}/ppp/pppoe.conf \
64 ${sysconfdir}/ppp/firewall-standalone \
65 ${sysconfdir}/ppp/firewall-masq"
66CONFFILES_${PN}-server = "${sysconfdir}/ppp/pppoe-server-options \
67 ${sysconfdir}/default/pppoe-server"
68
69INITSCRIPT_PACKAGES = "${PN}-server"
70INITSCRIPT_NAME_${PN}-server = "pppoe-server"
71INITSCRIPT_PARAMS_${PN}-server = "defaults 92 8"
72
73RDEPENDS_${PN} = "ppp"
74RDEPENDS_${PN}-server = "${PN}"
75RRECOMMENDS_${PN} = "ppp-oe"
76