blob: 9b73b442abdb4ee4af6df108d0cf8ee8215ddc7b [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "ATA over Ethernet Tools"
2DESCRIPTION = " \
3The aoetools are programs for users of the ATA over Ethernet (AoE)network \
4storage protocol, a simple protocol for using storage over anethernet LAN. \
5The vblade program (storage target) exports a blockdevice using AoE. \
6"
7HOMEPAGE = "http://sourceforge.net/projects/${BPN}"
8SECTION = "admin"
9LICENSE = "GPLv2"
10LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
11RRECOMMENDS_${PN} = "kernel-module-aoe"
12
13SRC_URI = "http://sourceforge.net/projects/${BPN}/files/${BPN}/${BPN}-${PV}.tar.gz \
14 file://aoe-stat-no-bashism.patch \
Patrick Williamsddad1a12017-02-23 20:36:32 -060015 file://makefile-add-ldflags.patch \
Patrick Williamsb48b7b42016-08-17 15:04:38 -050016 "
17SRC_URI[md5sum] = "bff30daa988a65f69d4448ce4726a6db"
18SRC_URI[sha256sum] = "fb5e2cd0de7644cc1ec04ee3aeb43211cf7445a0c19e13d6b3ed5a8fbdf215ff"
19
20# EXTRA_OEMAKE is typically: -e MAKEFLAGS=
21# the -e causes problems as CFLAGS is modified in the Makefile.
22EXTRA_OEMAKE = ""
23
24do_install() {
25 oe_runmake DESTDIR=${D} install
26}