blob: 2bc7d97879094392c9d409a5a946c7a96bbbe149 [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001SUMMARY = "Combined traceroute and ping utility"
2DESCRIPTION = "mtr combines the functionality of the 'traceroute' and 'ping' programs in a single network diagnostic tool."
3HOMEPAGE = "http://www.bitwizard.nl/mtr/"
4SECTION = "net"
5DEPENDS = "ncurses"
6
7LICENSE = "GPLv2"
8LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
9 file://ui/mtr.c;beginline=5;endline=16;md5=af1fafbbfa1bfd48af839f4bb3221106"
10
11PV .= "+git${SRCPV}"
12
Brad Bishop15ae2502019-06-18 21:44:24 -040013SRCREV = "6cddfc6e8f0e20af4af218b545f83d43b3f9a387"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050014SRC_URI = "git://github.com/traviscross/mtr"
15
16S = "${WORKDIR}/git"
17
18inherit autotools pkgconfig
19
20EXTRA_OECONF = "--without-gtk"
21
22PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}"
23PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
24
25PACKAGES += "${PN}-bash-completions"
26
27FILES_${PN}-bash-completions = "${datadir}/bash-completion/"