blob: c26b3838e1387b974c925106891f45c14e3d1fcf [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Python GObject bindings"
2HOMEPAGE = "http://www.pygtk.org/"
3SECTION = "devel/python"
4LICENSE = "LGPLv2.1"
5LIC_FILES_CHKSUM = "file://COPYING;md5=a916467b91076e631dd8edb7424769c7"
6
Brad Bishop15ae2502019-06-18 21:44:24 -04007GNOMEBASEBUILDCLASS = "meson"
Andrew Geissler1548c072019-02-22 16:03:50 -06008inherit gnomebase gobject-introspection distutils-base upstream-version-is-even
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08009
Andrew Geissler1548c072019-02-22 16:03:50 -060010DEPENDS += "python glib-2.0"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080011
Andrew Geissler1548c072019-02-22 16:03:50 -060012SRCNAME = "pygobject"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080013SRC_URI = " \
14 http://ftp.gnome.org/pub/GNOME/sources/${SRCNAME}/${@gnome_verdir("${PV}")}/${SRCNAME}-${PV}.tar.xz \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080015"
16
Brad Bishop15ae2502019-06-18 21:44:24 -040017SRC_URI[md5sum] = "9d5dbca10162dd9b0d03fed0c6cf865d"
18SRC_URI[sha256sum] = "32c99def94b8dea5ce9e4bc99576ef87591ea779b4db77cfdca7af81b76d04d8"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080019
20S = "${WORKDIR}/${SRCNAME}-${PV}"
21
Brad Bishop15ae2502019-06-18 21:44:24 -040022UNKNOWN_CONFIGURE_WHITELIST = "introspection"
23
24PACKAGECONFIG[cairo] = "-Dpycairo=true,-Dpycairo=false, cairo python-pycairo, python-pycairo"
25PACKAGECONFIG[tests] = "-Dtests=true, -Dtests=false, , "
26
27
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080028BBCLASSEXTEND = "native"
Brad Bishop15ae2502019-06-18 21:44:24 -040029RDEPENDS_${PN} = "python-setuptools"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080030RDEPENDS_${PN}_class-native = ""
31
32do_install_append() {
33 # Remove files that clash with python3-pygobject; their content is same
Andrew Geissler1548c072019-02-22 16:03:50 -060034 rm -r ${D}${includedir}/pygobject-3.0/pygobject.h ${D}${libdir}/pkgconfig
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080035}