blob: b46445a2ba7163eed83e5ff9a8a5306f7ff13b56 [file] [log] [blame]
Brad Bishop15ae2502019-06-18 21:44:24 -04001SUMMARY = "The Geolocation Service"
2DESCRIPTION = "Geoclue is a D-Bus service that provides location information. \
3The primary goal of the Geoclue project is to make creating location-aware applications \
4as simple as possible, while the secondary goal is to ensure that no application \
5can access location information without explicit permission from user."
6LICENSE = "GPLv2.0+"
7SECTION = "console/network"
8
9LIC_FILES_CHKSUM = "file://COPYING;md5=bdfdd4986a0853eb84eeba85f9d0c4d6"
10
11DEPENDS = "glib-2.0 dbus json-glib libsoup-2.4 intltool-native"
12
13inherit meson pkgconfig gtk-doc gobject-introspection vala
14
15SRC_URI = " \
16 https://gitlab.freedesktop.org/geoclue/geoclue/-/archive/${PV}/geoclue-${PV}.tar \
17"
18
19SRC_URI[md5sum] = "6228301ed62b587ebaa0438b97ce66e4"
20SRC_URI[sha256sum] = "3caa5e10190a34c17a9b3a9d1d8a19797ed197f07f36f6e35ce533a379efe155"
21
22export BUILD_SYS
23export HOST_SYS
24export STAGING_INCDIR
25export STAGING_LIBDIR
26
27# Without this line, package is declared a library and named libgeoclue*
28AUTO_LIBNAME_PKGS = ""
29
30PACKAGECONFIG ??= "3g modem-gps cdma nmea lib"
31PACKAGECONFIG[3g] = "-D3g-source=true,-D3g-source=false,modemmanager"
32PACKAGECONFIG[modem-gps] = "-Dmodem-gps-source=true,-Dmodem-gps-source=false,modemmanager"
33PACKAGECONFIG[cdma] = "-Dcdma-source=true,-Dcdma-source=false,modemmanager"
34PACKAGECONFIG[nmea] = "-Dnmea-source=true,-Dnmea-source=false,avahi"
35PACKAGECONFIG[lib] = "-Dlibgeoclue=true,-Dlibgeoclue=false,gobject-introspection"
36
37GTKDOC_MESON_OPTION = "gtk-doc"
38
39EXTRA_OEMESON += " \
40 -Ddbus-sys-dir=${sysconfdir}/dbus-1/system.d \
41 -Ddemo-agent=false \
42"
43
44FILES_${PN} += " \
45 ${datadir}/dbus-1/system-services \
46 ${libdir} \
47 ${systemd_unitdir} \
48 ${prefix}/libexec \
49"
50
51FILES_${PN}-dev += " \
52 ${datadir}/dbus-1/interfaces \
53 ${datadir}/gir-1.0 \
54"