blob: 07045121108aa1e49195ddd2abd9b1d1cc56c05a [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "Microsoft project for cloud-based client-server communication in native code using a modern asynchronous C++ API design."
2SECTION = "libs/network"
3HOMEPAGE = "https://github.com/Microsoft/cpprestsdk/"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://${S}/license.txt;md5=a2e15b954769218ff912468eecd6a02f"
6DEPENDS = "openssl websocketpp zlib boost brotli"
7
8EXTRA_OECMAKE = "-DCPPREST_EXPORT_DIR=cmake -DCPPREST_EXCLUDE_BROTLI=OFF"
9
10SRC_URI = "git://github.com/Microsoft/cpprestsdk.git;protocol=https;branch=master \
11 file://disable-float-tests.patch \
12 file://disable-outside-tests.patch "
13
14# tag 2.10.13
15SRCREV= "9d8f544001cb74544de6dc8c565592f7e2626d6e"
16
17S = "${WORKDIR}/git"
18
19inherit cmake pkgconfig
Brad Bishop15ae2502019-06-18 21:44:24 -040020
21# Temporary until https://github.com/Microsoft/cpprestsdk/issues/1099
22# is fixed properly
23CXXFLAGS += "-Wno-error=deprecated-copy -Wno-error=redundant-move"