blob: 4ee06d77f17dc4a2d26a5e84c6c8a911c096145d [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "ImageMagick is an image conversion toolkit"
Brad Bishopd7bf8c12018-02-25 22:55:05 -05002SECTION = "console/utils"
Brad Bishop19323692019-04-05 15:28:33 -04003HOMEPAGE = "https://www.imagemagick.org/"
4DESCRIPTION = "ImageMagick is a collection of tools for displaying, converting, and \
5editing raster and vector image files. It can read and write over 200 image file formats."
Brad Bishopd7bf8c12018-02-25 22:55:05 -05006LICENSE = "ImageMagick"
Brad Bishop34ae6002019-04-08 15:21:03 -04007LIC_FILES_CHKSUM = "file://LICENSE;md5=05ff94b3ff59fe6fa7489fa26e3d9142"
Brad Bishopd7bf8c12018-02-25 22:55:05 -05008# FIXME: There are many more checked libraries. All should be added or explicitly disabled to get consistent results.
Brad Bishop34ae6002019-04-08 15:21:03 -04009DEPENDS = "lcms bzip2 jpeg libpng tiff zlib fftw freetype libtool"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050010
11BASE_PV := "${PV}"
Brad Bishop15ae2502019-06-18 21:44:24 -040012PV .= "_47"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050013SRC_URI = "git://github.com/ImageMagick/ImageMagick.git "
Brad Bishop15ae2502019-06-18 21:44:24 -040014SRCREV = "b672df7a44b0ab0219b1fa78b3673c2810ddd374"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050015
16S = "${WORKDIR}/git"
17
18inherit autotools pkgconfig update-alternatives
19
20# xml disabled because it's using xml2-config --prefix to determine prefix which returns just /usr with our libxml2
21# if someone needs xml support then fix it first
22EXTRA_OECONF = "--program-prefix= --program-suffix=.im7 --without-perl --disable-openmp --without-xml --disable-opencl"
23
24CACHED_CONFIGUREVARS = "ac_cv_sys_file_offset_bits=yes"
25PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}"
26PACKAGECONFIG[graphviz] = "--with-gvc,--without-gvc,graphviz"
27PACKAGECONFIG[jp2] = "--with-jp2,,jasper"
28PACKAGECONFIG[lzma] = "--with-lzma,--without-lzma,xz"
29PACKAGECONFIG[openjpeg] = "--with-openjp2,--without-openjp2,openjpeg"
30PACKAGECONFIG[pango] = "--with-pango,--without-pango,pango cairo"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080031PACKAGECONFIG[rsvg] = "--with-rsvg,--without-rsvg,librsvg"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050032PACKAGECONFIG[webp] = "--with-webp,--without-webp,libwebp"
33PACKAGECONFIG[wmf] = "--with-wmf,--without-wmf,libwmf"
34PACKAGECONFIG[x11] = "--with-x,--without-x,virtual/libx11 libxext libxt"
35
36FILES_${PN} += "${libdir}/ImageMagick-${BASE_PV}/config-Q16* \
37 ${datadir}/ImageMagick-7"
38
39FILES_${PN}-dev += "${libdir}/ImageMagick-${BASE_PV}/modules-Q16/*/*.a"
40
41FILES_${PN}-dbg += "${libdir}/ImageMagick-${BASE_PV}/modules-Q16/*/.debug/*"
42
43BBCLASSEXTEND = "native"
44
45ALTERNATIVE_PRIORITY = "100"
46
47ALTERNATIVE_${PN} = "animate compare composite conjure convert display \
48 identify import mogrify montage stream"
49
50ALTERNATIVE_TARGET[animate] = "${bindir}/animate.im7"
51ALTERNATIVE_TARGET[compare] = "${bindir}/compare.im7"
52ALTERNATIVE_TARGET[composite] = "${bindir}/composite.im7"
53ALTERNATIVE_TARGET[conjure] = "${bindir}/conjure.im7"
54ALTERNATIVE_TARGET[convert] = "${bindir}/convert.im7"
55ALTERNATIVE_TARGET[display] = "${bindir}/display.im7"
56ALTERNATIVE_TARGET[identify] = "${bindir}/identify.im7"
57ALTERNATIVE_TARGET[import] = "${bindir}/import.im7"
58ALTERNATIVE_TARGET[mogrify] = "${bindir}/mogrify.im7"
59ALTERNATIVE_TARGET[montage] = "${bindir}/montage.im7"
60ALTERNATIVE_TARGET[stream] = "${bindir}/stream.im7"
61
62ALTERNATIVE_${PN}-doc = "animate.1 compare.1 composite.1 conjure.1 \
63 convert.1 display.1 identify.1 import.1 mogrify.1 montage.1 stream.1"
64
65ALTERNATIVE_LINK_NAME[animate.1] = "${mandir}/man1/animate.1"
66ALTERNATIVE_TARGET[animate.1] = "${mandir}/man1/animate.im7.1"
67ALTERNATIVE_LINK_NAME[compare.1] = "${mandir}/man1/compare.1"
68ALTERNATIVE_TARGET[compare.1] = "${mandir}/man1/compare.im7.1"
69ALTERNATIVE_LINK_NAME[composite.1] = "${mandir}/man1/composite.1"
70ALTERNATIVE_TARGET[composite.1] = "${mandir}/man1/composite.im7.1"
71ALTERNATIVE_LINK_NAME[conjure.1] = "${mandir}/man1/conjure.1"
72ALTERNATIVE_TARGET[conjure.1] = "${mandir}/man1/conjure.im7.1"
73ALTERNATIVE_LINK_NAME[convert.1] = "${mandir}/man1/convert.1"
74ALTERNATIVE_TARGET[convert.1] = "${mandir}/man1/convert.im7.1"
75ALTERNATIVE_LINK_NAME[display.1] = "${mandir}/man1/display.1"
76ALTERNATIVE_TARGET[display.1] = "${mandir}/man1/display.im7.1"
77ALTERNATIVE_LINK_NAME[identify.1] = "${mandir}/man1/identify.1"
78ALTERNATIVE_TARGET[identify.1] = "${mandir}/man1/identify.im7.1"
79ALTERNATIVE_LINK_NAME[import.1] = "${mandir}/man1/import.1"
80ALTERNATIVE_TARGET[import.1] = "${mandir}/man1/import.im7.1"
81ALTERNATIVE_LINK_NAME[mogrify.1] = "${mandir}/man1/mogrify.1"
82ALTERNATIVE_TARGET[mogrify.1] = "${mandir}/man1/mogrify.im7.1"
83ALTERNATIVE_LINK_NAME[montage.1] = "${mandir}/man1/montage.1"
84ALTERNATIVE_TARGET[montage.1] = "${mandir}/man1/montage.im7.1"
85ALTERNATIVE_LINK_NAME[stream.1] = "${mandir}/man1/stream.1"
86ALTERNATIVE_TARGET[stream.1] = "${mandir}/man1/stream.im7.1"