blob: c72df6d5e3be54bca954c32ef5dbf0b992abbac8 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "Library for using PKCS"
2DESCRIPTION = "\
3Libp11 is a library implementing a small layer on top of PKCS \
4make using PKCS"
Brad Bishop15ae2502019-06-18 21:44:24 -04005HOMEPAGE = "https://github.com/OpenSC/libp11"
6BUGTRACKER = "https://github.com/OpenSC/libp11/issues"
Brad Bishopd7bf8c12018-02-25 22:55:05 -05007SECTION = "Development/Libraries"
8LICENSE = "LGPLv2+"
9LIC_FILES_CHKSUM = "file://COPYING;md5=fad9b3332be894bab9bc501572864b29"
10DEPENDS = "libtool openssl"
11
12SRC_URI = "git://github.com/OpenSC/libp11.git"
Brad Bishop15ae2502019-06-18 21:44:24 -040013SRCREV = "973d31f3f58d5549ddd8b1f822ce8f72186f9d68"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050014
15S = "${WORKDIR}/git"
16
17inherit autotools pkgconfig
18
19EXTRA_OECONF = "--disable-static"
20
21do_install_append () {
22 rm -rf ${D}${libdir}/*.la
23 rm -rf ${D}${docdir}/${BPN}
24}
25
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080026FILES_${PN} += "${libdir}/engines*/pkcs11.so"
27FILES_${PN}-dev += "${libdir}/engines*/libpkcs11${SOLIBSDEV}"