blob: 63a64fc7120b0a04e7c4e0b0625d664e2389a19d [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001# This recipe is modified from the recipe originally found in the Open-Switch
2# repository:
3#
4# https://github.com/open-switch/ops-build
5# yocto/openswitch/meta-foss-openswitch/meta-oe/recipes-support/open-vm-tools/open-vm-tools_10.0.5.bb
6# Commit 9008de2d8e100f3f868c66765742bca9fa98f3f9
7#
8# The recipe packaging has been relicensed under the MIT license for inclusion
9# in meta-openembedded by agreement of the author (Diego Dompe).
10#
11
12SUMMARY = "Tools to enhance VMWare guest integration and performance"
13HOMEPAGE = "https://github.com/vmware/open-vm-tools"
14SECTION = "vmware-tools"
15
16LICENSE = "LGPL-2.0 & GPL-2.0 & BSD & CDDL-1.0"
17LIC_FILES_CHKSUM = "file://LICENSE;md5=559317809c5444fb39ceaf6ac45c43ac"
18LICENSE_modules/freebsd/vmblock = "BSD"
19LICENSE_modules/freebsd/vmmemctl = "GPL-2.0"
20LICENSE_modules/freebsd/vmxnet = "GPL-2.0"
21LICENSE_modules/linux = "GPL-2.0"
22LICENSE_modules/solaris = "CDDL-1.0"
23
24SRC_URI = "git://github.com/vmware/open-vm-tools.git;protocol=https \
Brad Bishop15ae2502019-06-18 21:44:24 -040025 file://tools.conf \
26 file://vmtoolsd.service \
27 file://vmtoolsd.init \
28 file://0001-configure.ac-don-t-use-dnet-config.patch;patchdir=.. \
29 file://0002-add-include-sys-sysmacros.h.patch;patchdir=.. \
30 file://0003-Use-configure-test-for-struct-timespec.patch;patchdir=.. \
31 file://0004-Fix-definition-of-ALLPERMS-and-ACCESSPERMS.patch;patchdir=.. \
32 file://0005-Use-configure-to-test-for-feature-instead-of-platfor.patch;patchdir=.. \
33 file://0006-Use-configure-test-for-sys-stat.h-include.patch;patchdir=.. \
34 file://0007-Fix-subdir-objects-configure-error.patch;patchdir=.. \
35 file://0008-include-poll.h-instead-of-sys-poll.h.patch;patchdir=.. \
36 file://0009-Rename-poll.h-to-vm_poll.h.patch;patchdir=.. \
37 file://0010-use-posix-strerror_r-unless-on-gnu-libc-system.patch;patchdir=.. \
38 file://0011-Use-uintmax_t-for-handling-rlim_t.patch;patchdir=.. \
39 file://0012-Use-off64_t-instead-of-__off64_t.patch;patchdir=.. \
40 file://0013-misc-Do-not-print-NULL-string-into-logs.patch;patchdir=.. \
41 file://0014-Fix-new-warnings-from-gcc9.patch;patchdir=.. \
42"
Brad Bishop19323692019-04-05 15:28:33 -040043# stable-10.3.5
44SRCREV = "f2ff192717375b95a6b7e278fb47dbb3d3bc56d1"
45
46S = "${WORKDIR}/git/open-vm-tools"
47
48DEPENDS = "glib-2.0 glib-2.0-native util-linux libdnet procps libtirpc"
49
50# open-vm-tools is supported only on x86.
51COMPATIBLE_HOST = '(x86_64.*|i.86.*)-linux'
52
53inherit autotools pkgconfig systemd update-rc.d
54
55SYSTEMD_SERVICE_${PN} = "vmtoolsd.service"
56
57EXTRA_OECONF = "--without-icu --disable-multimon --disable-docs \
58 --disable-tests --without-gtkmm --without-xerces --without-pam \
59 --disable-grabbitmqproxy --disable-vgauth --disable-deploypkg \
60 --without-root-privileges --without-kernel-modules"
61
62NO_X11_FLAGS = "--without-x --without-gtk2 --without-gtk3"
63X11_DEPENDS = "libxext libxi libxrender libxrandr libxtst gtk+ gdk-pixbuf"
64PACKAGECONFIG[x11] = ",${NO_X11_FLAGS},${X11_DEPENDS}"
65
66# fuse gets implicitly detected; there is no --without-fuse option.
67PACKAGECONFIG[fuse] = ",,fuse"
68
69CFLAGS_append_toolchain-clang = " -Wno-address-of-packed-member"
70FILES_${PN} += "\
71 ${libdir}/open-vm-tools/plugins/vmsvc/lib*.so \
72 ${libdir}/open-vm-tools/plugins/common/lib*.so \
73 ${sysconfdir}/vmware-tools/tools.conf \
74"
75FILES_${PN}-locale += "${datadir}/open-vm-tools/messages"
76FILES_${PN}-dev += "${libdir}/open-vm-tools/plugins/common/lib*.la"
77
78CONFFILES_${PN} += "${sysconfdir}/vmware-tools/tools.conf"
79
80RDEPENDS_${PN} = "util-linux libdnet fuse"
81
82do_install_append() {
83 ln -sf ${sbindir}/mount.vmhgfs ${D}/sbin/mount.vmhgfs
84 install -d ${D}${sysconfdir}/vmware-tools
85 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
86 install -d ${D}${systemd_unitdir}/system
87 install -m 644 ${WORKDIR}/*.service ${D}${systemd_unitdir}/system
88 else
89 install -d ${D}${sysconfdir}/init.d
90 install -m 0755 ${WORKDIR}/vmtoolsd.init ${D}${sysconfdir}/init.d/vmtoolsd
91 fi
92 install -m 0644 ${WORKDIR}/tools.conf ${D}${sysconfdir}/vmware-tools/tools.conf
93}
94
95do_configure_prepend() {
96 export CUSTOM_DNET_NAME=dnet
97 export CUSTOM_DNET_LIBS=-L${STAGING_LIBDIR}/libdnet.so
98}
99
100INITSCRIPT_PACKAGES = "${PN}"
101INITSCRIPT_NAME_${PN} = "vmtoolsd"
102INITSCRIPT_PARAMS_${PN} = "start 90 2 3 4 5 . stop 60 0 1 6 ."
103
104python() {
105 if 'networking-layer' not in d.getVar('BBFILE_COLLECTIONS').split() or \
106 'filesystems-layer' not in d.getVar('BBFILE_COLLECTIONS').split():
107 raise bb.parse.SkipRecipe('Requires meta-networking and meta-filesystems to be present.')
108}