blob: 3a437659e785b05febd15aba15d4855ae07a1965 [file] [log] [blame]
Brad Bishop15ae2502019-06-18 21:44:24 -04001SUMMARY = "Protocol plugin for New Yahoo (2016) for Adium, Pidgin, Miranda and Telepathy IM Framework"
2SECTION = "webos/services"
3LICENSE = "GPLv3.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=84dcc94da3adb52b53ae4fa38fe49e5d"
5
6DEPENDS = "pidgin json-glib glib-2.0"
7
8inherit pkgconfig
9
10SRC_URI = "git://github.com/EionRobb/funyahoo-plusplus;branch=master;protocol=git"
11SRCREV = "fbbd9c591100aa00a0487738ec7b6acd3d924b3f"
12
13S = "${WORKDIR}/git"
14
15do_compile() {
16 oe_runmake CC="${CC}" CXX="${CXX}" EXTRA_INCLUDES="${TARGET_CFLAGS}" AR="${AR}";
17}
18
19do_install() {
20 oe_runmake DESTDIR="${D}" install;
21}
22
23FILES_${PN} += " \
24 ${libdir} \
25"