blob: 3b3e31dd9790de09362a5bdf8fb926e80996fa75 [file] [log] [blame]
Brad Bishop15ae2502019-06-18 21:44:24 -04001SUMMARY = "Capture::Tiny - Capture STDOUT and STDERR from Perl, XS or external programs."
2DESCRIPTION = "Capture::Tiny provies a simple, portable way to capture \
3almost anything sent to STDOUT or STDERR, regardless of whether it comes \
4from Perl, from XS code or from an external program. Optionally, output can \
5be teed so that it is captured while being passed through to the original \
6filehandles. Yes, it even works on Windows (usually). Stop guessing which of \
7a dozen capturing modules to use in any particular situation and just use \
8this one."
9SECTION = "libs"
10
11HOMEPAGE = "http://search.cpan.org/~dagolden/Capture-Tiny/"
12
13LICENSE = "Artistic-1.0 | GPL-1.0+"
14LIC_FILES_CHKSUM = "file://LICENSE;md5=37a4918a30ace24395020e5b8c03b83f"
15
16SRCNAME = "Capture-Tiny"
17SRC_URI = "${CPAN_MIRROR}/authors/id/D/DA/DAGOLDEN/${SRCNAME}-${PV}.tar.gz"
18SRC_URI[md5sum] = "f5d24083ad270f8326dd659dd83eeb54"
19SRC_URI[sha256sum] = "6c23113e87bad393308c90a207013e505f659274736638d8c79bac9c67cc3e19"
20
21S = "${WORKDIR}/${SRCNAME}-${PV}"
22
23inherit cpan ptest-perl
24
25RDEPENDS_${PN} = " \
26 perl-module-carp \
27 perl-module-exporter \
28 perl-module-extutils-makemaker \
29 perl-module-extutils-mm-unix \
30 perl-module-file-spec \
31 perl-module-file-temp \
32 perl-module-io-handle \
33 perl-module-lib \
34 perl-module-overloading \
35 perl-module-perlio \
36 perl-module-perlio-scalar \
37 perl-module-scalar-util \
38 perl-module-strict \
39 perl-module-test-more \
40 perl-module-warnings \
41"
42
43RDEPENDS_${PN}-ptest += "perl-module-perlio"
44
45BBCLASSEXTEND = "native"