blob: 44a915c5b7c2f769ae8f7c3b3302a711b77d38c6 [file] [log] [blame]
Brad Bishop15ae2502019-06-18 21:44:24 -04001SUMMARY = "Test::Deep - Extremely flexible deep comparison"
2DESCRIPTION = "If you don't know anything about automated testing in Perl \
3then you should probably read about Test::Simple and Test::More before \
4preceding. Test::Deep uses the Test::Builder framework. \
5\
6Test::Deep gives you very flexible ways to check that the result you got is \
7the result you were expecting. At its simplest it compares two structures \
8by going through each level, ensuring that the values match, that arrays and \
9hashes have the same elements and that references are blessed into the \
10correct class. It also handles circular data structures without getting \
11caught in an infinite loop. \
12\
13Where it becomes more interesting is in allowing you to do something besides \
14simple exact comparisons. With strings, the \'eq\' operator checks that 2 \
15strings are exactly equal but sometimes that's not what you want. When you \
16don't know exactly what the string should be but you do know some things \
17about how it should look, \'eq\' is no good and you must use pattern matching \
18instead. Test::Deep provides pattern matching for complex data structures \
19distribution."
20
21SECTION = "libs"
22
23HOMEPAGE = "http://github.com/rjbs/Test-Deep/"
24
25LICENSE = "Artistic-1.0 | GPL-1.0+"
26LIC_FILES_CHKSUM = "file://lib/Test/Deep.pm;beginline=1817;endline=1826;md5=aebc793c87a3d8771fe98d5d369898e7"
27
28SRC_URI = "${CPAN_MIRROR}/authors/id/R/RJ/RJBS/Test-Deep-${PV}.tar.gz"
29SRC_URI[md5sum] = "9bc47147ea720fc01bc6b214afb884ff"
30SRC_URI[sha256sum] = "852d7e836fba8269b0b755082051a24a1a309d015a8b76838790af9e3760092f"
31
32UPSTREAM_CHECK_REGEX = "Test\-Deep\-(?P<pver>(\d+\.\d+))(?!_\d+).tar"
33
34S = "${WORKDIR}/Test-Deep-${PV}"
35
36inherit cpan ptest-perl
37
38RDEPENDS_${PN} += " \
39 perl-module-dynaloader \
40 perl-module-exporter \
41 perl-module-fcntl \
42 perl-module-list-util \
43 perl-module-scalar-util \
44 perl-module-strict \
45 perl-module-vars \
46 perl-module-warnings \
47"
48
49RDEPENDS_${PN}-ptest += " \
50 perl-module-if \
51 perl-module-lib \
52 perl-module-test-more \
53 perl-module-test-tester \
54"
55
56BBCLASSEXTEND = "native"