blob: 9ff4df2c93f1f58295167752476e1d1cf322eab7 [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001SUMMARY = "A pure-Python SNMPv1/v2c/v3 library"
2DESCRIPTION = "SNMP v1/v2c/v3 engine and apps written in pure-Python. \
3 Supports Manager/Agent/Proxy roles, scriptable MIBs, asynchronous \
4 operation (asyncio, twisted, asyncore) and multiple transports.\
5"
6HOMEPAGE = "https://pypi.python.org/pypi/pysnmp"
7SECTION = "devel/python"
8LICENSE = "BSD"
Brad Bishop15ae2502019-06-18 21:44:24 -04009LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=b15d29f500f748d1c2a15709769090a8"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050010
11SRCNAME = "pysnmp"
12
13SRC_URI = "https://files.pythonhosted.org/packages/source/p/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
14
Brad Bishop15ae2502019-06-18 21:44:24 -040015SRC_URI[md5sum] = "6d1b514997326bed18f1ae1510f6b1c9"
16SRC_URI[sha256sum] = "d5d1e59780126e963dd92e25993b783295734e71bef181f602e51f7393260441"
17
Brad Bishop6e60e8b2018-02-01 10:27:11 -050018
19S = "${WORKDIR}/${SRCNAME}-${PV}"
20
21inherit setuptools
22
23RDEPENDS_${PN} += "python-pycrypto \
24 python-pyasn1 \
25 python-pysmi \
26"