blob: 32d52a6f610ec26f06ade549e7fab9e69e473bb8 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Debugging and profiling extension for PHP"
2LICENSE = "Xdebug"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=92d94a330d34ee6edc2638450736f119"
4
5DEPENDS = "php re2c-native"
6
7SRC_URI = "http://xdebug.org/files/xdebug-${PV}.tgz"
8
Brad Bishop15ae2502019-06-18 21:44:24 -04009SRC_URI[md5sum] = "5d1a8ca3101df93938d283933f256493"
10SRC_URI[sha256sum] = "b0f3283aa185c23fcd0137c3aaa58554d330995ef7a3421e983e8d018b05a4a6"
Brad Bishop19323692019-04-05 15:28:33 -040011
12UPSTREAM_CHECK_REGEX = "xdebug-(?P<pver>\d+(\.\d+)+)\.tgz"
13
14inherit autotools
15
16EXTRA_OECONF += "--enable-xdebug -with-php-config=${STAGING_BINDIR_CROSS}/php-config"
17
18do_configure() {
19 cd ${S}
20 ${STAGING_BINDIR_CROSS}/phpize
21 cd ${B}
22
23 # Running autoreconf as autotools_do_configure would do here
24 # breaks the libtool configuration resulting in a failure later
25 # in do_compile. It's possible this may be fixable, however the
26 # easiest course of action for the moment is to avoid doing that.
27 oe_runconf
28}
29
30do_install() {
31 oe_runmake install INSTALL_ROOT=${D}
32}
33
34FILES_${PN} += "${libdir}/php*/extensions/*/*.so"
35FILES_${PN}-dbg += "${libdir}/php*/extensions/*/.debug"