blob: 929d853486267e6b514e3cf5ff10ced4da32eb87 [file] [log] [blame]
Brad Bishop15ae2502019-06-18 21:44:24 -04001DESCRIPTION = "IMA/EVM control utility"
2LICENSE = "GPL-2.0-with-OpenSSL-exception"
3LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
4
5DEPENDS += "openssl attr keyutils"
6
7DEPENDS_class-native += "openssl-native keyutils-native"
8
9PV = "1.0+git${SRCPV}"
10SRCREV = "0267fa16990fd0ddcc89984a8e55b27d43e80167"
11SRC_URI = "git://git.code.sf.net/p/linux-ima/ima-evm-utils"
12
13# Documentation depends on asciidoc, which we do not have, so
14# do not build documentation.
15SRC_URI += "file://disable-doc-creation.patch"
16
17# Workaround for upstream incompatibility with older Linux distros.
18# Relevant for us when compiling ima-evm-utils-native.
19SRC_URI += "file://evmctl.c-do-not-depend-on-xattr.h-with-IMA-defines.patch"
20
21# Required for xargs with more than one path as argument (better for performance).
22SRC_URI += "file://command-line-apply-operation-to-all-paths.patch"
23
24SRC_URI += "\
25 file://0001-ima-evm-utils-link-to-libcrypto-instead-of-OpenSSL.patch \
26 file://0002-ima-evm-utils-replace-INCLUDES-with-AM_CPPFLAGS.patch \
27 file://0003-ima-evm-utils-include-hash-info.gen-into-distributio.patch \
28 file://0004-ima-evm-utils-update-.gitignore-files.patch \
29"
30S = "${WORKDIR}/git"
31
32inherit pkgconfig autotools
33
34EXTRA_OECONF_append_class-target = " --with-kernel-headers=${STAGING_KERNEL_BUILDDIR}"
35
36# blkid is called by evmctl when creating evm checksums.
37# This is less useful when signing files on the build host,
38# so disable it when compiling on the host.
39RDEPENDS_${PN}_append_class-target = " util-linux-blkid libcrypto attr libattr keyutils"
40
41BBCLASSEXTEND = "native nativesdk"