blob: 3352daa034ace0a4bb367f3510dc05574b5c42f3 [file] [log] [blame]
Brad Bishop15ae2502019-06-18 21:44:24 -04001SUMMARY = "IMA sample hash policy"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
4
5# This policy file will get installed as /etc/ima/ima-policy.
6# It is located via the normal file search path, so a .bbappend
7# to this recipe can just point towards one of its own files.
8IMA_POLICY ?= "ima_policy_hashed"
9
10SRC_URI = " \
11 file://${IMA_POLICY} \
12"
13
14do_install () {
15 install -d ${D}/${sysconfdir}/ima
16 install ${WORKDIR}/${IMA_POLICY} ${D}/${sysconfdir}/ima/ima-policy
17}
18
19FILES_${PN} = "${sysconfdir}/ima"
20RDEPENDS_${PN} = "ima-evm-utils"